Not sure about origin of that decision, when Ashley implement animations, but i've always assumed it's design that way in specific purpous - to let you combine different things to set animation name.
Sprite: set animation to "weapon_" &loopindex
Sprite: set animation to global_var
Which is extremely useful.
You would not be able to do that with lists.
btw. Ashley would it be possible to add AnimationNameCount (or AnimationCount, or whatever)?