Spriter objects only showing first frame in game

  • Ok, I've given this over 12 hours of my time and googled my brains out. Attached is an image of my walk system. It worked perfectly when I used PNG sprite animations, but when I use spriter objects it only shows the first frame of every animation. I checked to make sure the animations worked with the platform template and they work fine so it must be doing something weird. I'm guessing it's re-starting the animation every click, but if that was true why did the sprites work? If anyone has an idea on how to get this to work, it would be greatly appreciated. I honestly am at a lose. I'm making a graphic adventure game and everything was working perfectly until I took out my sprite animations and replaced them with spriter objects.

    One weird thing, when no animation is set and the game starts (before I give the walk a new target) the idle_right animation plays fine. It's after I walk, talk or do anything else that the animations only show the first frame (including the idle animation).

  • Try putting the condition "trigger once while true" on the events that have the animations. On the events that have the simulate control and the animation, create another sub-event and put the animation there with the trigger once condition.

  • Dear son of science, that worked! Thank you so much! I didn't even know that was an option!

    I mean, wow, thank you so much! Seriously, if anyone else runs into this "trigger once while true" totally solves this problem.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Yeah you were right on the first post, the issue was that the animation was resetting every tick. I'm glad it worked.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)