Sprite Images getting distorted/Corrupted on Windows Phone

  • [attachment=0:39jk97k2][/attachment:39jk97k2]

    Problem Description

    I am making a side scrolling game, where I am spawn Platforms above the Game layout. They gradually move downwards or to the left side. The game works perfectly on Windows 8.1 and the Construct 2 "Run Layout" in browser.

    But when I port the same game to Windows Phone, the images are getting distorted/corrupted! This is not happening with all images.

    I am using 256x160 sized tiles for Platforms and repeating 512x512 sprites for background/borders. Its the border images that causing the problem.

    Attach a Capx

    I would love to upload. But my company policies restrict me from doing so.

    It has got many Artworks /sprites that we cant share yet.

    However, here is a screenshot of the issue.

    [attachment=1:39jk97k2][/attachment:39jk97k2]

    Description of Capx

    1. Spawn Platforms and background at regular interval.

    2. These will scroll to the left and then get destroyed

    3. I have a Player Sprite that performs standard platform moves (up down, left right)

    4. Have coins/items appearing at random platforms which the player can collect

    Steps to Reproduce Bug

      Only on Windows Phone. Appears immediately the game is started. Game works well on Computer browser and as a Windows 8.1 app.

    Affected Browsers

    • Chrome: (NO)
    • FireFox: (NO)
    • Internet Explorer: (NO)

    Operating System and Service Pack

    Windows 8.1 Enterprise Edition x64 bit

    Visual Studio 2013 Pro

    Construct 2 Version ID

    Construct 2 Beta release r177

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)