[solved] NW.js 0.13 Beta4 broken?

0 favourites
  • 8 posts
  • There is a thread in the Bug-Reports with something similar, but not exactly the same problem and the solution doesn't work for me.

    The problem is, if I export to NWjs or start the preview in Construct it only works once. After closing the app, all nw.js tasks I can see in the Task-Manger get closed too. But if I start the preview or execute the exported app a second time, two tasks appear in the Task-Manager and nothing happens. I have to rename the project in Construct or delete the folder with the name of the app in <username>/AppDate/local and kill the tasks, then it works once again.

    This is with the exported 32 Bit version, the 64 Bit version crashes immediately.

    I use Windows 7 home premium 64 Bit with Construct 221 and NW.js 0.13 Beta4. The question is, I am the only one with this problem? Could someone test if he/she has the same problem?

    Edit: I think I found the culprit. I seemed my old Node.js install had caused problems. After uninstall node.js, nw.js and construct and reinstall construct and nw.js it now works.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • i have also the same problem exported to nwjs last version, 32bits works, 64bits is not working files are missing!!!!

  • I can't really write more that I have. I uninstalled all, looked if NWjsForC2 is complete deleted, deleted node_modules in User/<Username>/ and reinstalled all.

  • This is the problem we have with the last build of construct2

    when we export to desktop 32/64bits app get the top bar you see on the picture....

    ALSO!!!! 64bits exported version don't work under windows 7 64bits!!!!

  • Have you tried to completely uninstall NWjs, even looked if the folder is deleted and then reinstalled it?

    I had in my export some wired folder named alt and neu (old and new) and there was a nwjs exe in it what opened an empty screen with an address-bar.

    But after the reinstall it all worked without a problem.

    I suggest in hindsight, that the old nwjs 0.12 caused the problem not my old node.js.

    Have you installed the new beta 4 over the old nwjs installation?

  • i reinstalled ALL my os windows 7 64bits, reinstalled all my licences, still the same problem with last build construct2.

  • Sorry, then I can't really help. After reinstall, all works for me.

    Have you tried to export an empty project to see if the problem appears?

    Maybe is a problem with a plugin.

  • i use no plugin at all.... oh yes....mouse, and keyboard.........maybe thats a problem???

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)