A single variable won't sync (MP)

0 favourites
  • 4 posts
From the Asset Store
Easily store, modify, read and manipulate colors with Color Variables!
  • Hey all,

    I'm getting along nicely with my MP game, but one final bugbear exists: the 'name' instance variable of an object just won't sync! All the others sync absolutely fine, and there are a lot of them on a number of different objects. Only the 'name' variable of the 'skill' array won't and I am baffled as to why.

    I have searched all event sheets top to bottom and there is nothing at all that is changing the variable (as is backed up by the fact that the variable behaves properly for the host). So has anyone had any experience with this? Can you think of anything I may need to check? There is a workaround I can think of, but really it's not optimal.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • it might sound silly but i would check and make sure everything for it is spelled the same because sometimes its the simple to fix (i know your going to say youve done that already but check again most of the time its the simplest things )

    other then that i think we need to see the code to help more (like a screen shot or .capx )

  • volkiller730 Ha, yeah I know it's always good to double check these things. I just solved one issue I had for ages because I was not converting a string to an integra.

    But this is pretty clear cut: sync object, sync variables, one variable won't sync. I attached some images, the first is what the peer gets, the second what the host has, and third is the events.

    As you can see, the team syncs no problem, but the name won't change. Even other text variables work okay, so not sure what's going on.

  • So I tried manually syncing through messages, and again I get something very weird!

    In the attached images, you can see how the events work. And they do work, for all 'skills' except one! It for some reason places the array contents into the name variable! Perhaps someone can see where this is going wrong?

    EDIT: Found the issue with this one, there was a pipe sign in the array contents. Oops!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)