Seamless option for Tilemap?

  • Is it possible to create a seamless option for the Tilemap? This way we could use it in high quality games. Is it planned? Because it was in the 9 patch object, so just curious why it's not the option here.

  • Not really, not at least how the 9-patch does it. In the 9-patch image each section of the image is connected to the other parts. In a tilemap the tiles aren't necessarily meant to be connected to one another. The 9-patch seamless option draws 1px of overlap to cover up seams and that works since the image parts are connected, but in a tilemap, that would just cause an unrelated tile to bleed in to the seam.

  • You just need to make your tiles appropriately to hide your seams--this is how it is almost always done. Heck, I have to turn off the 1px thing in the 9patch plugin (change it to exact) because I make my tiles to work from the get-go. The 1px overlap actually makes it look worse in some cases.

  • C-7: how to do that with the tilemap plugin? (can't really simulate pixel rounding just for the tilemap and tiles are strictly sized according to tile width and height)

  • You don't, you make your art assets seamless in your art program by drawing carefully and adjusting accordingly.

    And you can round pixels by using a grid of 1px by 1px or greater. You should turn this on when you start any layout.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • So your reply was not related to the tilemap object, thus not relevant to this topic. Okay.

  • Ashley, I don't think the 1 pixel overlap is an issue if you design around this with large tiles anyway, it would enable a lot of non-pixel games to be made.

    But if it's technically impossible then yeah don't worry about it.

  • Ashley

    So I hope I am posting this in the correct spot. I am working on a title that used the tilemap plugin for the game boards. Here is a screen cap of the seam I am getting. I had my artist deliver the assets in a seamless fashion but i still get them. Is this a bug or do I need to find another way of hiding the seam somehow. I follow the steps suggested in other posts regarding the pixel rounding and sampling but nothing seems to be working.

    As you can see in the image, I may just have to place a sprite ontop as a work around but I would prefer not to do that.

    Thanks in advance for any help you can give.

    -Mike

    <img src="http://rcmadiax.tripod.com/figure2.PNG" border="0" />

  • Nutzaboutpoker If you can still see the seams and you have linear sampling and pixel rounding turned on, then you need to overlap the images by 1 pixel.

  • alspal

    Sorry for my lack of experience here, but how do I go about doing that?

    -Mike

  • Depends which part you are referring too. Project properties will let you change settings.

    https://www.scirra.com/manual/66/projects

  • alspal I believe he meant the 1 pixel overlap

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)