Screen flashing with NWjs / Audio related

  • I'm still getting the flickering even after the most recent updates. It's really random for me tho. It will happen multiple times in a minute and then not happen at all until I run another preview. Only happens in fullscreen for me.

  • I rolled back to 0.13. No flickering.

  • It works fine with NWjs 0.18.1. I have no flickering any more.

    0.13.x - no flickering

    0.14.x to 0.17.x - gives flickering

    0.18.x - no flickering

    I tested it only for around 10 minutes, but usually it started flickering within a minute, so I'm pretty sure it's fixed.

    I think you got a game on Steam right (congrats btw), might want to check out their reviews.

    The more different setups we test this on, the better we can identify and hopefully find a fix for this bug.

    I rolled back to 0.13. No flickering.

    I'm not on Ashley's level when it comes to things with the web but I've had similar issues to this one in the past with native software and directX.

    For me this all sounds like there is something terribly wrong with the drivers, this doesn't necessarily mean that you guys are at fault.

    No, it might be more of a bug from NWjs's side of things, however if that would be the case then you'd also experience this in Chrome itself.

    I would like to request a basic example.capx where this bug is occurring so that I (and maybe others) could investigate it.

    If you got some free time, I'd very much appreciate if you could share the following helpful information:

    • Basic info about your graphics and cpu drivers
    • Any 3rd party plugins that you use, even if they don't seem to be related to this
    • The content of all 3 package.json files found in your nwjs folder (X:\xxx\Construct2\Construct2-Win64\exporters\html5\nwjs) You can upload those files to make things simple, they are just about 3KB big.

    What you also could do right away is to clean install the latest version of NWjs.

    At first use the uninstaller and then go back to the actual folder and delete everything that's left (nwjsforC2 folder only).

    As useless as this sounds, I had my fair share of "experiences" with NWjs and I got them fixed by exactly doing that twice already.

    Thanks for your time and looking forward to the helpful information.

  • I think you got a game on Steam right (congrats btw), might want to check out their reviews.

    The more different setups we test this on, the better we can identify and hopefully find a fix for this bug.

    Thanks. I've released it with NWjs 0.13.2, so there will most probably be no feedback regarding this flickering. I'm busy with other things now, but once I'm done I'll try to replicate it and simplify capx as much as possible. We'll see if we can identify the issue. I think it is purely NWjs issue. There's no flickering when you test in Chrome. But I'm not an expert and as NWjs team ignored this issue stating it's not their fault, then maybe it's not. They know more than me. And it's also weird that it's related to the Audio plugin. I'll update the capx when I'm done.

    I'm still getting the flickering even after the most recent updates.

    Hmm... I'll surely give it some more tests. Thanks.

  • Thanks. I've released it with NWjs 0.13.2, so there will most probably be no feedback regarding this flickering. I'm busy with other things now, but once I'm done I'll try to replicate it and simplify capx as much as possible. We'll see if we can identify the issue. I think it is purely NWjs issue. There's no flickering when you test in Chrome. But I'm not an expert and as NWjs team ignored this issue stating it's not their fault, then maybe it's not. They know more than me. And it's also weird that it's related to the Audio plugin. I'll update the capx when I'm done.

    OK sounds like the classic case of passing the blame, if the problem persists in the newer versions (v19+) I will start another bug report on their git.

    They won't be able to get rid of me that easily.

    Anyway, do you have the link to the report for me? I'd like to check it out by myself.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Anyway, do you have the link to the report for me? I'd like to check it out by myself.

    Yeah it's actually mentioned a bit up in this thread, but here you go: https://github.com/nwjs/nw.js/issues/4947

  • Yeah it's actually mentioned a bit up in this thread, but here you go: https://github.com/nwjs/nw.js/issues/4947

    Whoops, I should've paid more attention thanks either way.

    Looks exactly how I expected it to be, just earlier today I saw a guy getting bashed in a topic about this "passing the blame" issue that's happening frequently.

    Well I guess we are on our own, since this issue doesn't seem to happen within chrome, their team will blame it on the software or back-end we use.

    Keeping things short we either enter the endless loop of waiting and getting nothing done or do it by ourselves.

  • Okay now I'm really confused.

    I tried with NWjs 0.15 and I had no flickering any more as well.

    So I thought maybe it's something in the project. I use SVN as I work in team, so I reverted my project to the exact same state as when I was reporting this issue here. And still no flickering.

    Then I decided to make an exactly same setup as before so I reverted C2 to r234 and still no flickering O.o.

    I'm out of ideas now. It looks like it is related to something absolutely external. Windows version? Graphic drivers? Maybe Chromium 50+ is not compatibile with some drivers which has been recently updated?

    No idea, but tomorrow I will have an access to the second machine I had this flickering issue, so I'll test it there as well. But if it's related to the machine itself (I mean not to C2 or NWjs) then I guess it's still better to use 0.13.2 for a while now as this version is working well everywhere while 0.18 might work well only on PCs with latest Win, graphic drivers (or whatever it is) updates.

  • Just an additional thought: I noticed I could cause the flickering to happen more frequently when I spammed my jump button on the keyboard (W). It wouldn't really happen when I was just walking. For reference, my game is just a platformer and this was with the platformer behavior.

  • Just an update on this. I'm currently on r239 and NWjs 0.18.1, so the same setup I tested earlier and had no flickering. Now I just turned off and on music in my game (not in the code) few times and now it's flickering again pretty often when the sound is triggered in my game (but not everytime). Usually when my object hits an obstacle. Switching on/off music in my game is simply Audio->Stop(tag)/Audio->Play(tag).

    Just an additional thought: I noticed I could cause the flickering to happen more frequently when I spammed my jump button on the keyboard (W). It wouldn't really happen when I was just walking. For reference, my game is just a platformer and this was with the platformer behavior.

    I presume there's a sound triggered while you jump in your game?

  • Do you guys preload all sounds or are they playing (+loading in) for the first time?

  • Do you guys preload all sounds or are they playing (+loading in) for the first time?

    Sounds are preloaded at start of the game.

  • I presume there's a sound triggered while you jump in your game?

    Yes there is! I was actually getting flickering in my test level which has no music but has SFX for shooting and jumping. Looks like it is audio related!

  • I've made a CAPX with this bug. Tested on two machines and reported as bug:

  • Great work. Thanks for taking the initiative on this.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)