Preview server not working

0 favourites
  • 9 posts
From the Asset Store
2D fighting template based in the game that defined the fighting games genre.
  • This is very frustrating, especially because I have NEVER had an issue in the past. Ive properly port forwarded. Have all correct IP's and ports specified.

    My preview server is not working. I used to click play/preview, the game opens on my browser of my choosing and I can then connect to the browser on my phone or tablet by typing in the ip.

    This no longer works.

    In fact, I cant even choose my browser. No matter what browser I choose chrome opens up. I even did the custom browser option and directed it to a firefox exe file. It opened up chrome.

    I would love a solution, Im getting very close to completion on my project...and now I cant easily test things. Exporting and generating xcode, then installing on my phone each time is NOT a solution.

  • I would guess the network configuration of your system/LAN was changed. AFAIK the C2 preview server is working fine for everyone else.

  • I would guess the network configuration of your system/LAN was changed. AFAIK the C2 preview server is working fine for everyone else.

    What I really can't figure out though is why I can't choose the browser I want it to use, which is why I'm left thinking something must be going on with the construct side of things.

    I'm def going to look into my own router and network settings further, but think there's another issue going on here.

  • Actually it sounds like some software configuration on your system has changed.

  • I solved the browser issue. For some reason I can't choose the browser from file-preferences/settings

    I had to choose the browser from the project properties.

    Still no luck on getting external devices to connect though. Any ideas what might be the cause? I've made sure the port is open and forwarded. I've tried to connect my phone while on wifi and on cellular, didn't make a difference. Also attempted both the public IPv4 and local network IP's with no luck.

  • Hi. I installed the latest beta (r241) and lan preview does not work for me either. It was fine in the past and the firewall ports etc. are still set up properly. Any ideas? :/

  • It seems preview does not work in Edge with Preview over LAN. When I try Chrome or Safari on my iPhone I can see the preview but Edge shows this error:

    Leider können wir nicht auf diese Seite zugreifen.

    Probieren Sie Folgendes

    Stellen Sie sicher, dass Sie die richtige Webadresse verwenden:

    Seite aktualisieren

    Gewünschte Informationen suchen

  • Any idea why preview does not work in Edge when I enable LAN preview?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Bl4ckSh33p

    just stumbled across your post

    you will need a more knowledgeable person than me to explain why this works

    it is something about edge being a universal app and not allowing loopback calls for security reasons.

    to enable loopback exemption (and thus preview over lan) specifically for MS edge,

    do the following...

    open command prompt as admin

    (Type CMD in the windows search

    right click >open as administrator)

    copy this text in at the prompt

    CheckNetIsolation LoopbackExempt -a -n=Microsoft.MicrosoftEdge_8wekyb3d8bbwe[/code:71tk1v26]
    and press enter
    [b]you should get an OK message[/b]
    [b]restart edge[/b]
    and all should be well with the world now.  
    @scirra maybe this should be pinned or be included in the lan preview tutorial for other edge users
Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)