Pender Android for Phonegap Cordova

  • OK, so I got it installed. Always love learning new stuff :).

    Anyway, now when I try to build with Pender I get

    $ ./pendertools -p /c/java/kaplow-pend.zip

    PenderTools: Creating Library Project

    ./pendertools: line 81: android: command not found

    grep: invalid option -- o

    Usage: grep [OPTION]... PATTERN [FILE]...

    Try `grep --help' for more information.

    android create lib-project --name Pender --target 0 --path /c/java/kaplow-pend.z

    ip/PenderAndroidLibrary --package com.pender

    ./pendertools: line 73: android: command not found

    I don't expect you know how to help with this, but figured I would post it up :).

    Ya, I got the same but it still worked. That might have something to do with C2's runtimejs file, web font, something else in our games that it doesn't support yet, or maybe that's why it's still in beta.

  • How can you tell if it's been injected?

  • This sounds like exactly what CocoonJS does. If you try to run from within PhoneGap's webview, you run in to serious performance issues with communicating with the webview. (I know about this since I went as far as making a plugin to enable WebGL support in PhoneGap, but it performed terribly - the overhead of communicating with PhoneGap made it slower than software rendering.) Perhaps this is why CocoonJS is still faster.

    Still, it might be nice for making PhoneGap better than it currently is.

  • ArcadEd I wasn't sure if it was either since there is no real conformation message in the prompt. Well that and the errors. That is why I made 2 versions of my game to test against each other, and as you can see from the screenshots there is a definite difference in fps, and it doesnt support web font just like CocoonJS. Maybe you should do the same and add some web font to your game just to make sure.

    Ashley I was hoping you would notice this thread. It would be great if you could take a look at it. I cant find much documentation on this, and it would be great if you could get PhoneGap better than it currently is.

  • OK, I was just checking because my ZIP file modified date didn't change at all.

    I'm going to follow your steps first (I was using Github for windows before and not cygwin) and see what it does.

    Ashley

    I do love CocoonJS and what they have accomplished. I just don't like their splash screen and monetizing options (mopub). That is why I like to build in eclipse, so I can manually add the admob sdk.

    If Cocoon every went to native admob and iads support, plus removed the cocoon splash screen, I would just do it that way. I would even pay for the service when/if they offer it.

  • Man, I can't confirm it's doing anything. My zip file modified time is never changing and neither is any of the files in the zip.

    I tested with phonegap build and it was just as slow as without, so I don't think it's actually injecting anything.

  • Wink

    Ok, so it seems like no matter what I put for the path, it always creates the libraries in the directory pendertools is located.

    It's called PenderAndroidLibrary

    I can delete it, run ./pendertools -p (no matter what I put here)

    it always goes into the pendertools directory. I've tried every which way to do a path, even duplicated your setup (app.zip in root of c, then used c:/app.zip)

  • Hmm, I wonder why it worked for me. I hope I just didn't get lucky or something. Maybe you could try injecting it before you zip it up, and see if that makes a difference. I will go back to searching the adobe past-bins to see if I can find any more info.

    Or try placing your game in the tools folder, and see if that works.

  • Yeah, tried that too.

    If you open up your zip, did it add any files too it?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • No, it didn't but I got that fps boost, and web font quit working.

    I haven't tried this yet but you could try the dev branch here:

    https://github.com/lorinbeer/pender-android/tree/dev

    And see if that makes a difference.

  • ArcadEd I just remembered the first time I ran the ./pendertools command I left the PenderAndroidLibrary in the tools folder and I never took it out when I ran ./pendertools -p C:/app.zip. I wonder if that made a difference.

    I'm just trying to figure out why it's not working for you.

  • I wish that was the issue, but I tried leaving it. From what I understand of the command help, using the -p should create that PenderAndroidLibrary folder wherever you specify the path. I even just created a blank folder and used it for the path and it doesn't create it there. It's like the path command doesn't work, it always creates it in the Tools directory whether I specify a path or not.

    I even tried different ways of using the path.

    c:\app.zip

    c:/app.zip

    /c/app.zip

    Always goes to the tools folder.

    I'm going to shoot you a PM and maybe you can download my zip and inject it and send it back to me? I can see if it works.

  • OK, I'll give it a try.

  • Thank you.

  • Your welcome. Check your PM box I really hope it works for you I did the same thing to it that I did to mine.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)