Outline shader bug(ish) appearance

  • I have used R0J0hound 's outline effect and noticed that the outline produces strange visuals while fading in/out (or have opacity other than 100) over objects with other WebGl effects.

    I tried to tweak the shader so it would not take image samples outside the box, but I failed

    Can someone explain what is happening or how that problem can be solved? Thank you.

    Simplest example:

  • Please, help me.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Does it still happen if the objects are on different layers?

    ~Sol

  • Does it still happen if the objects are on different layers?

    ~Sol

    Yes, it happens on same and different leyers , if I turn off an on "Force own texture" or "use render cells"...

    Furthermore in my project it even hapening when the opacity is 100, but I can't duplicate that bug outside my project.

    It looks that Constract 2 shaders works in a way that they don't clear memory after they rendered previous objects, and it messes up with current renderings...

  • Can you post the capx file here so I can take a look and see if there's a work-around perhaps?

    I already spoke to R0J0 today about this plugin/effect but he isn't working on webgl effects anymore for reasons, so a fix may not be possible at all - but I can have a look to see if I get the same results using different hardware and/or exported renderer.

    ~Sol

  • Webgl and my pc don't get along so I don't mess with shaders anymore and I won't be fixing this. It's probably the shader that's to blame and how I wrote it since issues have come up since I first made it.

    A possible workaround for the opacity would be put the object on it's own layer and change the layer opacity instead of the object opacity.

    The outline around the border could be from sampling garbage values outside of the quad. Maybe clamping the uv coordinants inside the shader could help to keep them inside the box.

  • Sounds like R0J0hound needs a new computer... I wonder what I have laying around here that I could stick in a box and send to you

    ~Sol

  • Link to capx: http://www.filedropper.com/outlinefail

    I figured out that in my project the problem is two outlines, even with 100 opacity:

  • The outline around the border could be from sampling garbage values outside of the quad.

    Exactly!

    I tried to clamp, but the garbage values can be found even in the quad...

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)