open link in facebook app half working

0 favourites
  • 2 posts
From the Asset Store
10 Orchestral Soundtracks / ~2 mins each / 11 audio clips in total
  • Hi All,

    I have an html5 website (built with Construct2) that includes a link to facebook.

    I'm using a Browser go-to-url action in that webpage to open the facebook link using the facebook app rather than the browser.

    This works just fine (assuming you're browsing with a phone and you have the facebook app installed).

    However I'm also working on an app that opens this same html5 webpage using a standard Browser go-to-url action. But when the page is opened from the app, the facebook link does not work. The facebook app does not launch, nothing happens at all.

    I've tried this on a few different handsets with the same result (Android only).

    I would have thought that the same browser would be used when the app launches the webpage, so I can't explain the different behaviour. I think I'm missing something important about the underlying workings here.

    Can anyone offer any advice?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Update: I had some more time to look at this tonight and I found that apps created with Construct2 don't seem to use the default android browser to open URLs. This is the process the lead me to that conclusion:

    -Updated website.

    -Cleared browser cache on phone.

    -Updated page displays in browser as expected.

    -Opening the same URL from within the app (on the same phone) displays an old version of the page.

    Can anyone confirm if apps created with Construct2 and build with Intel XDK use a different browser or browser cache?

    Trying to get my head around this one so I can put a decent solution together.


Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)