Odd FPS issues

  • Hi

    When i preview this with Chrome on the desktop i get about 10 FPS Idle.

    If i run it from the web its a 60FPS Idle (drops to 30 in use.)

    If i package it through Node web-kit and run it on the desktop it runs at 60 FPS

    I know there are lots of objects on screen (over 50,000) but its more of a test than a game. I just cant understand the slow speed with the chrome preview.

    dl.dropbox.com/u/84974566/test/index.html

  • Forgot to mention, doesnt run in firefox on my PC for some reason.

    Would be interested to know if it does on other machines ( regardless of speed )

    btw. I did try to edit my first post but i kept getting authentication errors.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Not able to check the capx at the moment, but previewing is slower than export because the preview code has a lot of checks for errors.

    The authentication errors are a forum bug, go to another page, come back and retry and it generally works after a try or two.

  • Using lots of tiny sprites to make destructible terrain is just about the least efficient thing you could possibly do, so I would not expect this to run well anywhere!

  • Thanks

    I realise i cant use this in any meaningful way but i just highlighted the difference between the preview and the Web output.

    I hadn't thought about the error checking etc slowing it down, makes sense i suppose <img src="smileys/smiley1.gif" border="0" align="middle" />

  • 45fps on Chrome idle, 25fps on Chrome moving around. Drops to 2fps on Chrome when firing. Processor's temp got quite high as well, 81C.

  • 45fps on Chrome idle, 25fps on Chrome moving around. Drops to 2fps on Chrome when firing. Processor's temp got quite high as well, 81C.

    Thanks for that. Just wondered if it works on Firefox at all ( regardless of speed)

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)