[NWjs] Level goes black - WebGL not working properly

  • Hello,

    Recently, I've made a build and decided to test it on several PC's. I brought the build to my friend and tested it out. That's when I encountered the bug with jump calculation inaccuracy. I managed to bypass it by tweaking jump height and gravity.

    Then, while I was testing one of the builds on another PC I've encountered a situation when one of the levels turned almost completely black. Only "UI", "Rain" and "Objects" layers appeared. Everything below it was black. I've tried to delete and remake every layer that was below "Objects", but it lead to nothing. Then, I've returned to the condition of the build that I've tested on my friend's PC and tried it out again (to make sure that the reason of this graphic bug was not the changes that I've made). I also tried to downgrade to the previous version of nwjs, but the result was the same.

    I think that the reason maybe in that particular PC, but I am not entirely sure of it. I've updated Java to the latest version, as well as DirectX. The graphic card drivers are not too old too. It runs on Windows 10 and the specs aren't so bad too. Has anyone encountered the same issue? I would like to fix that issue because I don't know what causes it and on how many PC's it will appear. Maybe the chance is 1 on 10 or maybe it's more.

    Big thanks in advance!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I'll add the screenshots so you can see what I'm talking about.

    Update: I consulted folks from C2 Discord community on this matter, and got the info that apparently this issue happens because WebGL is not working properly. The reason of this is unknown.

    Console shows this warning:

  • Problem solved! The tiled sprite that I used for the environment of the level is basically a monolith picture that was combined from smaller pieces (I know, it's wrong to use that big sprites ). Its size was 9600x1080 and it looks like it exceeded the maximum that older laptops can handle. I just replaced it with smaller parts of the level environment sprites and it works just fine now.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)