NW.JS no longer working

0 favourites
  • 8 posts
  • The other day i was working on my game, everything was swell. Had previewed it several times using nw.js, and exported a latest build as well. The build functioned properly.

    Than I got an idea for a new feature I wanted to play around with and started a new project to experiment. It was working fine under chrome. Then I tried to preview it under nw.js, and nothing happened. Tried again. Nothing. Switched back to chrome, runs fine. I tried to export it to its own .exe to see if that would work. It did its export thing and everything seemed ok, but when i tried to run the .exe, nothing happened. Then the wife came in and I was distracted and figured I'd deal with figuring out the problem later, assuming it was specific to the new project.

    Now today, I load up my game proper (not the experiment project), and it won't preview in nw.js either. Nor will the latest .exe build run. Both projects run under the different preview web browsers, however. NWJS does load as a background process whenever i try to preview/run the .exe. But no window pops up or anything.

    I'm using the steam build of construct 2 and I'm running windows 8.1 64bit.


  • Oh, and I'm using chrome 46 up to date. And in an effort to solve the problem myself, i updated to the latest nw.js alpha before i posted this, and that didn't help.

  • Can you post an example that doesn't work for us to test?

    What version of C2 are you using? Do you get the beta through steam?

    If so, have you tried the latest r217 and the new NW.js released today?

  • I'm on r216. I was using the 12.0 release of nw.js and updated to the 13.0 alpha an hour ago and that didnt work.

    I loaded up several of the included example projects/templates and none of them will preview either. I just went in and made a new project with no events, just a sprite on a blank layout. That won't load either.

  • dude, 13 works with 217+ only.

    follow the changelog of construct otherwise you miss a lot of things :/

  • Alright, I'll roll back to 12, but it still doesnt solve the original problem.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • If everything was working, then it suddenly stopped, it seems unlikely to me that it would be a C2 or NW.js problem. More likely it's an OS/Antivirus/GPU change that has triggered it.

    What happens when you run NW.js in debug?

    Maybe try an export with a keyboard action to show the devtools - might get some info from that.

    Have you got access to another machine that you could maybe install the release from today, along with today's release of NW.js? NB/ both available from HERE.

    Or even try to install standalone r217 in a new folder with the new NW,js.

  • Yeah, I didnt think it was a construct 2 problem. Anyways, uninstalled nw.js altogether and reinstalled 12 and that did the trick so clearly something got confused somewhere at some point. All better now. Thanks for the help guys.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)