Node webkit .exe doesn't work

0 favourites
  • 10 posts
From the Asset Store
Node Downloader is a plugin for download file for Construct 3 and construct 2 game engine
  • Hi all,

    I am trying to export via nodewebkit, but the resulting .exe won't open. It just puts the cursor's loading symbol up for a fraction of a second and that's it.

    I have used NW in the past a lot and never had any issue, so not sure what's going on. I notice the folder says 'win32' whereas I use 64 bit windows, but like I said, no issues in the past. If someone could try loading one, it would be great!

  • Tobye

    Tried your file. Just crashes straight away. Win 7 x64

    I export to node all the time and never have any issues ( so far ).

    Have you tried exporting without minify script on. There were some issues a while ago with that.

    What Version are you running ?

  • spongehammer - thanks for trying it out for me! And yep, I tried both ways. I'm using Windows 8 x64. Similarly I have never had issues before and have used it often in the past.

    Are you using the latest beta? It would be good if you could try to export to NW as well and see if you get the same problem (I have tried 3 different games of mine so far, none work).

  • Just got it working by reverting to version 146, same projects and no other changes. So this seems to be a bug with the new beta.

  • All of my r151 NW builds have been working, but they were just tools and editors. Are you using any 3rd party plugins?

  • Tobye

    Just checked on the latest beta and my stuff seems ok.

  • Hm, this is a worry then. The only 3rd party plugin I use is 'moveTo', which I expect every single user has ^^ Maybe some problem with my PC? Because now tried 3 that all didn't work with 151 but did work on 148.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • To find out more about node-webkit issues use the node-webkit plugin and 'show dev tools' on start of layout. Then providing there's not a javascript error that prevents the runtime starting up at all, you'll get a chrome devtools window with a console that you can look for errors in just like in the browser.

  • I noticed my nodewebkit exports work on windows but not mac machines osx 10.8.5. Will look into it further ...

  • I don't know if I'm allowed to jump in here and kind of hijack the thread but...

    Ashley: I get a black screen when running the .exe that is generated after node-webkit export (minified or not). I used 'show dev tools' from the plugin but nothing shows. I can only close the window by force quitting it in the taskmanager (win7pro)

    Is there any way to track down the java script error that assumingly is causing the crash?

    The game runs smooth when I run the layout.

    In the taskmanager I noticed that the .exe node-webkit exports runs 2 times simultaneously . That seems odd.


    SOLUTION: The issue seems to be resolved when 'Use loader layout' is set to 'No'. At the start of the layout I run some loops that generate unique combinations of numbers. This conflicts with the layout trying to load the other stuff that is happening apparantly.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)