Node Webkit crash

  • Since r184 I've a "little" problem about loading a game after exporting it with node webkit.

    I export the project, click on the .exe, the usually black window of node webkit appears but after few seconds windows (7 x64) tell me the .exe has stopped working. I thought was a little bug of r184 and waited for r185 but the problem is still there. I'm exporting without png compression and without minifying the script and leaving all the node webkit options at default (single instance, win frame and resizable).

    Anyone had the same problem? Ashley any advice? I didn't filed a bug report 'cause I didn't think it's project-related. (the preview in chrome works flawlessly)

  • Did you install the dxwebsetup.exe? I think the node webkit exported game needs it.

    (Not sure it is related to your problem, just a guess)

  • yes, directx installed :\

  • If you use 'on start of layout - show dev tools' (in the node-webkit object) does dev tools appear and are there any console messages?

  • Ashley : no, does not appear anything. black window and after few seconds windows tell me app has stopped working.

    a little hint i've just found: turning off webGL, the game starts, so can be a webGL problem?

  • Are your graphics drivers up to date? Maybe it's a driver problem.

  • Ashley just checked, ati catalyst 14.9 installed. do you advice to install beta driver? it's strange that with the same driver the r183 worked flawlessly :\

  • Ashley do you know how to load the project in the old r183?

  • PePPo

    Opening the capx file in a soft like winzip, export all the files (it makes the hierarchy like a saved folder), open the .caproj file in the notepad and modify the line with the tag "<saved-with-version>" to a number that correspond with the previous version you're trying to open the project in.

    Save the caproj file and open it in C2 it should work.

  • Lunatrap thanks a lot!

    Now, using r183, it works like a charm thanks again!

  • Ashley

    same problem on r187. tried also moving old node webkit directory in the new (Program Files\NodeWebkitForC2) but with no solution.

    Maybe it's something related to exportation?

    back to r183...

  • We haven't updated the node-webkit version, it's still 0.10.5. So I guess it must be something different.

    I strongly suspect this is a graphics driver issue, especially if turning off WebGL fixes it.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Ashley

    installing now beta driver (catalyst 14.9.2), i'll tell you if something change.

  • Ashley

    same results with beta driver..

    i'm stuck with r183 then :any advice will be appreciated, thanks.

  • I'd still guess it's the graphics driver, especially if it works with WebGL off. Just because it's up to date doesn't mean it works

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)