Need help immediatelly because no ad showed at all

0 favourites
  • 5 posts
From the Asset Store
Game with complete Source-Code (Construct 3 / .c3p) + HTML5 Exported.
  • Hi guys...

    I'm currently working on putting admob plugin from C2 but it's not working at all.

    My ad unit ID in my project = not working

    My ad unit ID in Kyatric test ad project = not working

    Others ad unit ID in my project = not working

    Others ad unit ID in Kyatric test ad project = not working either

    I've been exported them all into apk file using PhoneGap Build, Intel XDK, Cordova, even Android Studio, but they're all the same, the ad didn't show up anywhere at all

    I've been doing some research of my own looking for any trouble that could happen to me and I found some:

    • someone said it was country fill rate problem
    • some other said admob account verification problem
    • some other again said it was our coding inside C2 project
    • some other of other said related to layout properties or something like that
    • some other of another said etc.

    I've got no more to say because i've been struggling with this admob thing for almost 2 weeks but nothing or failure as result

    I won't provide any capx due to it's useless to provide one.

    why useless?? i've got so many capxs and all of them are useless or not working at all.

    I tried all that apk files in 2 different devices, Oppo Neo 7 and Samsung Galaxy Tab 10.1 and nothing happen, no ad showed.

    I also change my mobile provider to the fast one in internet connection just to make sure that it wasn't about connection problem and it was still the same, nothing showed up.

    so, is there anyone can suggest me something else?

    Because being a mobile app developer is dizzy, right? and that's what are forum for.

    and lastly, thank you for anyone who read and try to help me.

  • What plugin do you use?

    What library do you use?

    Does the test AD unit work for you (for interstitial: ca-app-pub-3940256099942544/1033173712)?

    Also still the capx would be valuable to say anything.

  • at the moment, i'll try another way first then i'll come back to you..

    I just use admob native plugin from C2.

    does library you mean here is in android studio or what? because I don't get it.

    I just use Banner AD since my app don't get to well with interstitial for some reason, or do you mean I have to provide both codes (banner & interstitial) from admob in my C2 project to make it works?

    I can't provide my own capx due to privacy reason but next time I come back here, I will provide capx and also an apk file if possible.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • C2 AdMob plugin is just a kind of interface that triggers particular actions of the library (Cordova/Cocoon plugins).

    As the manual says you have to include to your project

    [quote:165rmysh]Name: AdMob Plugin

    Plugin ID:

    Check the 'Plugin is located in the Apache Cordova Plugins Registry' box

    I'm not sure if still works as I use Cocoon for a while now. But that's basically what I meant. You need an actual plugin to make ads work. The C2 plugin itself is not enough.

  • sorry to get back to you after all these days.

    I've found another way to make it work. I used Admob Pro (3rd party plugin) from

    So, I guess this matter had been solved. Sorry again to tell you this lately.

    Thank you for your attention and patience.

    Right now, I have another problem but i will post it in another topic due to it's different matter.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)