Multiplayer - Trigger Once not working on host

0 favourites
  • 3 posts
From the Asset Store
Change the size and position of everything without calculating anything!
  • I made a little test project using the multiplayer update. The goal is to make a server based system similar to the multiplayer game demo, but the host doesn't play. For the demo I made a little spaceship game and got the movement working, but when I tried to get firing to work, I couldn't get it to fire just a single time when you push the button. I tried multiple ways, but every time it keeps firing repeatedly. Looking at it in debug, I see that the variables or bools that I use to try to stop it from firing change correctly, but it still keeps firing.

    Here's the capx:

    Sorry about the lack of commenting. I was just throwing it together for myself quick.

    There's a bunch of other weird things that I haven't gotten to yet. For now I'm just trying to get this portion to work. I'm testing it on two computers inside the same network. No idea if that has anything to do with it. I also haven't tried more than one peer yet, just working first on getting it to work once.

  • Have you seen the third multiplayer tutorial? It covers how to make a "trigger once" work per-instance on the host. BTW your link doesn't work here.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I'd read it. Problem was a stupid mistake in my logic. Whoops.

    Don't know why the link didn't work. I copied it directly from OneDrive.

    Now, on to the rest of the weirdnesses I'm running into.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)