Made a mistake, can't save or load!

0 favourites
  • 11 posts
From the Asset Store
Template for a generic save / load system, fully documented in comments and video
  • Hello!

    Let me first say that I'm very new to Construct 2. I am not sure if the following problem is due to a bug or some mistake on my part.

    I have been trying to learn the program using the free version. I was about 5 hours in to making my first test game. This morning I tried to load the project only to find that it is completely blank. I does open, but all of the work is gone. It is as though I am opening a blank new project.

    Also, I can't save anymore. Ctrl s doesn't work and I notice the save button is greyed out.

    Any thoughts on what the problem is?

    Thank you!

  • Firstly, did you save regularly and make use of the autosave and autobackup? If not, then you may have to accept a harsh lesson, which is awful, I know

    Secondly, is it possible for you to attach the .capx to your post so we can test it ourselves?

    It is possible that saving is disabled due to reaching the limits of the free version (see here:

  • Heh, I did save regularly. But it if this is a limitation of the free version, as you say, then that is the case. I just overlooked it in the description of the program! I'll have to look at the description again. Thank you for pointing that out!

  • The limit doesn't include making your project empty - it would just not allow you to save anymore, which is why I suggested you let us try it for ourselves. That sounds a little strange.

  • Here it is. It will probably just open as a blank document. If it does in fact open, it will have a star tile bg with a rudimentary spaceship and point and click movement controls.


  • Oops.I messed up. Let me try again.

  • As I said, I'm very new to this and showing the file didn't work like I thought it would. How do I post the file?

  • Instead of 'quick reply', scroll back to the top and use 'Post a Reply' -- this will give you attachment options down at the bottom. (You could also upload your file to dropbox or Google drive and post a shared link.)

  • i cant help with you losing you game but construct greys out the save bottom when no changes have been made since last save

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Ah! I think that worked! Thanks for the tip.

    Thought it won't save when I haven't done anything, it troubles me when I can't save new work after starting a new project. I just tried a new project again and the save function is working again. Maybe I had a different project loaded or something.

    The space ship file is still blank. If anyone would like to give it a look please do.

  • Unfortunately it is as as bad as you thought.

    There is nothing that anyone can do for this projects as everything has been deleted. Even the whole Animations folder is missing, which is strange.

    Did you have the backup option set? Is there a file with the .backup extension in the folder?

    Out of curiosity, what physical location was you loading/saving the project to? Was it a local drive or a virtual,i.e. usb, dropbox, google drive etc?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)