Can no longer preview my game.

0 favourites
  • 4 posts
From the Asset Store
five golem elements Sprites Sheet.Best for enemy or villain game characters.
  • Hi. A weird problem just occured, which I haven't been able to fix. When I attempt to preview my game using either Firefox, Chrome or Node-Webkit nothing happens after Construct implies that the preview is "ready". None of the browsers open a new tab with the game, and Node-Webkit doesn't boot. This only happens with my own project however (clean project boots just fine), so I wonder if I've turned off some setting by hitting a hotkey combination by accident?

    I've tried rebooting the computer, didn't help. I would also like to add that I didn't add any new assets from the time it worked flawlessly earlier in the day, to now where nothing happens.

    Any ideas why it doesn't work?

    Edit: I just tried exporting the game to Node-Webkit. PNGcrush and PNGout crashes instantly. Is there a chance my image files have gotten corrupt somehow?

    Edit 2: Reloaded a backup of the project from some time back (which had no problems at the time I backed up). Didn't work either. Starting to suspect it's construct that's the problem and not my project.


    (Help me )

  • Which version of C2 are you using?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Edit: I just tried exporting the game to Node-Webkit. PNGcrush and PNGout crashes instantly. Is there a chance my image files have gotten corrupt somehow?

    If that would be the case I guess your capx wouldn't open.

    Perhaps if you posted it for us to confirm or see if there is a configuration issue.

    To be sure, check out the several project's properties and perhaps try to modify some.

    On the other hand, you might want to check for errors in browser (although this does require a tab to open) or troubleshoot C2's preview server (even though the issue should also apply to other projects as well).

    Last thing, if you have configured to be [url= over LAN/WI-FI and are not executing C2 as an admin, there will be a dialog displaying when previewing that will tell you "Unable to start HTTP server".

    Clicking "OK" executes preview on a normal basis.

    Nevertheless from time to time this dialog instead of appearing on top of all windows UI will simply appear in the background and the preview won't happen before you've clicked OK.

    This might be something worth to check out too.

    Here are clues to investigate.

  • Hmm after doing some digging I've managed to get the preview to boot if I write "http://localhost:50000" manually into a tab. However I cannot get it to boot directly by pressing the preview button inside construct. Also PNGcrush and PNG out instantly crashes even on a clean project with only 3 random images added.

    Any thoughts?

    Edit: Hmm actually the export was successful regardless of the PNG compression apparently crashing (Though it takes foreeeever).

    Actually I've tracked it down to it crashing once the compression's been completed. If I close all windows manually it completes the export. However as my project opens hundreds of these exporter windows I can't practially do anything...

    Edit: 2 Using the latest version released.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)