LAN Previewing Issue

0 favourites
  • 5 posts
  • I have ran into my first problem here.

    I have followed the online tutorial on activating LAN previewing and everything is all set up correctly (I kept the default ports Construct 2 has in the preferences.)

    I have a Google Nexus tablet here and whenever I access Chrome and enter the address that is displayed on my desktop browser nothing shows up on the tablets browser.

    Everything is setup correctly, I have made a new rule in Windows Firewall for Construct 2 and I have also checked 'Run as Administrator' from the .exe file (I am using Construct 2 on Steam and found the .exe file from within my Steam directory).

    I am running as admin and the ports are the default ones but all I get on my tablets browser is a blank page.

    Any help is appreciated. I do have Norton Antivirus on my desktop if that makes any difference, I also have no port forwarding on my router either and I am running Windows 10.

    If you need anymore info or screenshots or photos, let me know



  • When you run the previewer on the desktop, do you get an IP address ? or is: localhost:50000 ?

    Also, have you tried disabling all the security for a bit to test if it works ? (disable antivirus and firewall, then test)

  • Hey lennaert, I haven't tried disabling anything but I do get an IP address (192.168.x.x:50000).

    I will try disabling my Norton and see if that helps at all. I followed the tutorial and added a rule for Construct 2 and I also run the program as admin.

    I'll post back if disabling my Norton doesn't get it working.


  • Sorry to ask the obvious, do you have a license?

    That'll get the big one out the way.

    Most anti virus programs have a custom firewall type bulit in. you might need to add c2 and port 50000 as an exception.

    Also helps to go into your router an allocate a constant ip for your c2 pc.

    and shooting in the dark, you make any edits to the host file???

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hi guys, so I tried disabling my firewall for Norton and that didn't seem to work.

    DUTOIT, haha thats a fair question lol. I have the personal license

    I haven't tried adding an expection for C2 in my Norton but I have in Windows Firewall. I will try out my router settings and mess around there to see if that gets it working.

    Will let you know what happens xD


Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)