Jump animation not working

  • 1 - I create event -> is jumping set animation to "jump".

    2 - The jump animation have 4 frames.

    3 - but when I jump the frame does not leave the 0, the animation is just static.

    4 - I've done several tests, with loops and no loops, speed and others but not work.

    My english is very bad, sorry for this.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Try using the "On jump" event instead of "Is jumping". The latter will be true while you are jumping, so the animation will start over and over again.

  • I 've used " on jump" , but did not work , using on jump the animation is not called .

  • Can you share you capx with me (or a simplified version), so I can take a look at it?

  • I'm at work now. I'll send when at home. But have a problem, my project language is PT BR. It is my first project . Thanks for your help.

  • I do not have permission to send private message.

  • Each tick you are setting the jump animation to play from the beginning.... Which means a reset to frame zero each tick, and thus an apparent lack of playing the animation. You need to add a 'trigger once' or use another trigger event to set the animation change only once. As you have it, the same problem will be apparent for the fall animation as well.

  • Each tick you are setting the jump animation to play from the beginning.... Which means a reset to frame zero each tick, and thus an apparent lack of playing the animation. You need to add a 'trigger once' or use another trigger event to set the animation change only once. As you have it, the same problem will be apparent for the fall animation as well.

    Work *----*

    Thank you so much.

    thanks glerikud too.

  • Colludium was faster Happy developing martdsam .

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)