Intel XDK Export = Black Screen

  • When I export my Construct 2 capx into Intel XDK, it works fine in the emulator.

    When I use the App.Lab app or the apk, the phones only show a black screen.

    I've tried to research it but wherever it comes up, they are either a year old (before Intel acquired Appmobi XDK) or are options I've already tried.

    I'm not using pugins, I've tried to disable minify script, and I've tried multiple Construct 2 versions. I would say its an issue with XDK, but I feel as if I'm missing something more evident.

    EDIT:

    Tested on iPhone 4S and Chrome app - after exporting from XDK, the game is broken. Unlike Android, it runs but its usually half the screen and the touch buttons do not work.

  • You should probably contact Intel about this issue. We don't have any tools to diagnose compiled XDK apps, we can only work with the emulator, so if it works there we can't diagnose the problem. Only Intel can do that.

  • You should probably contact Intel about this issue. We don't have any tools to diagnose compiled XDK apps, we can only work with the emulator, so if it works there we can't diagnose the problem. Only Intel can do that.

    While I would, if you search for the issue and the symptoms - the only people with this problem appears to be mostly Scirra's Construct 2 people. And its either resolved in an update or something they change in their projects. Most of them are unspecified or never follow up.

    EDIT:

    Tested on iPhone 4S and Chrome app - after exporting from XDK, the game is broken. Unlike Android, it runs but its usually half the screen and the touch buttons do not work.

  • Hi

    Ive today also used the xdk

    with same problem.. black screen....

    also during test with App LaB

    Have you solved it ?

    Regards

    flemming

  • Hi

    Ive today also used the xdk

    with same problem.. black screen....

    also during test with App LaB

    Have you solved it ?

    Regards

    flemming

    I'm afraid not.

  • Hi, Im having the same issue on AGI XDK NEW. Anyone got it to work?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • ghost Be sure you're using the new export to Android (which using the new crosswalk stuff) option when exporting.

    When setting up a new project in XDK New be sure to copy and paste the files that were exported from C2 into the folder that you selected for your new project in Intel XDK New, replacing any files that show a conflict when pasting.

    Also, check this thread out as there seems to be a few things they're working out as we speak.

    http://www.scirra.com/forum/new-android-export-experiences_topic83062.html

    Hope this helps some.

  • hi man, sorry I should have been clearer, I'm using the AGI export.

  • ghost Astro AnthonyB28 Ashley

    Guys, I just updated Intel XDK to build 3491 and same, blackscreen,

    Anyone solved this?

    I get the blackscreen even if i compile the app as an .apk.

    What did i do wrong?

    Any new settings?

  • I think Intel said you have to make sure the Cordova "device" plugin is in the project or it won't work. Still, better to post on Intel's forums about this.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)