Image glitch in editor

0 favourites
  • 7 posts
From the Asset Store
Tweakable and easy to use effects for your projects.
  • Hey all,

    I have an issue where adding a new object or changing its image can result in the image getting squashed into a small portion of the object in the editor. It still displays correctly in game, but it prevents me from building a level at all.

    Here is an image of the problem. I get it quite frequently now, for both sprites and tiled backgrounds.

    I will try to make a bug report later, but it will require me stripping down my project and will take some time. So for now, does anyone have any solution for this?

  • It could be a driver problem. Are your graphics card drivers up to date? Is it the same on other systems?

  • Don't quite understand here...your image is hard to interpret without context. Don't think I've ever had this problem.

    If striping down your project is too much work, maybe you could try a video?

    Do you have another install of construct, like a sandbox version, you could try?

    Does it happen all the time, or randomly?

    Have you tried a new, test project, or is it just your project?

    Hope someone who knows more can chime in.

    Cheers, T

  • I got this standard when my sprites are bigger then 2048x2048

  • Ashley - I looks like it might be my drivers. I got someone else to try out a few examples of glitchy editor stuff, and in all cases it worked fine for them. Problem is, it seems I can't update my drivers.

    When I install a new C2 version it comes up with the 'check for driver updates', which I do, and it says they should be okay. Then even when I search and try to install them, it locks up when trying to detect my drivers, and when I search for the driver specifically it says it doesn't exist past windows 7. So...what to do? I am currently still on a place holder PC that is really junky, but not sure when I can get my old one back. So does this mean I'm stuck with these problems for the time being? I've found it's actually having a lot of different issues too (squashed images, blurry images and tilemaps going completely barmy)

  • Tobye - which OS are you using and what card do you have? Try identifying your card and manually locating the right driver instead of auto-detecting. Or, last resort, go for a reinstall of Windows, and update the drivers as soon as it's set up.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Ashley - I'm using windows 8 and my driver is: Intel(R) G41 Express Chipset (Microsoft Corporation - WDDM 1.1), which had the following note under it: An Intel device was detected but your operating system is not supported by this utility. Please visit Download Center to look for available software.

    So I searched for a new one and found this:

    Downloaded it, but my computer does not match the minimum requirements. So, I'm somewhat out of my depth. I've been trying for a while to get something working but no luck no matter which way I turn.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)