Help please, tempermental project.

0 favourites
  • 5 posts
From the Asset Store
Game with complete Source-Code (Construct 3 / .c3p) + HTML5 Exported.

    attached above is link to capx. I dont know how to explain this, I was using the global backwards and forwards thing with mouse only and everything was alright. Then yesterday I tried changing it to touch, tap on object with mouse/yes and everything went tits up and remained that way once I put it all back to mouse only again.

    Sometimes the global layer is visible sometimes it isnt, sometimes only some of it is visible in the browser, sometimes the project skips a page on clicking.

    I havent attached the capx for the original project because it is large, 18 layouts but I recreated the problem in a small way.

    I set the project up with mouse, changed it to touch tap, it went wrong, I put it back to mouse and it is still wrong.

    On layout1 the global layer shows up , then it doesnt, but the hotspot/links/ buttons (whatever you would call them) still work even though you cant see them... I am using chrome browser, I just updated Java but that has made no difference. I am on release 212.2 (64 bit). I cant see anything logical that would be causing this.

    Should I update to a beta version of Construct2, am I doing something wrong?

  • Should I update to a beta version of Construct2, am I doing something wrong?

    The latest version is r216 and is the stable version, so might be worth trying.

  • Will try it thanks and report back.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • ... .capx?dl=0

    ok tried previously posted capx in r216 and it was the same. Made this one in r216 starting with 'Touch/tap and it worked fine,, but then I added in the Mouse object and changed the events to mouse click on object and it went tits up too. So it has to be something to do with the changing the events from touch to mouse and vice versa? I would think so anyway. But does that mean that my big project that I started with only the mouse object made just for mouse is unfixable? I changed it all back to mouse events and deleted the touch object but it still decides to only show half the global screen sometimes...bamboozled.

  • Well I have fixed it. I replaced all mouse events with Rex's TouchMouse. Also I had the global sprites set as global so I put those to No as well and now it all seems ok.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)