Help exporting HTML5 (not working in chrome)

  • We finished 2 games and they work perfect in preview mode.

    When I export to HTML5, they don´t work in Chrome, but works ok in firefox.

    The screen stay black. Just the data.js is loaded and stop.

    Does anybody knows how can I solve it?

  • Not enough information. What does the chrome browser console say? Any errors? Are you using/have you tested in the latest chrome? Have you disabled addons?

  • Is it related to webgl? Perhaps chrome is disabling it, and maybe your game requires webgl if you are using certain effects, etc. I would check to see if webgl is working in your chrome browser.

  • You could try Scirra's own render performance test to see if webgl is working OK.

  • Sorry, it was the opposite.

    It works in Chrome, but it doesn´t work in Firefox.

    The "render performance test" works in Chrome but not in Firefox either.

    Here, in some PCs it worked for both, but in some notebooks just in Chrome.

    I´m looking for some configuration in Firefox to enable it.

    The screen stay black, No message error. Just the data.js is loaded and stops.

    Any help?

  • It´s strange that http://www.firstpersontetris.com/ and http://oos.moxiecode.com/js_webgl/xwing/ that uses webgl works in my Firefox.

    When I put "about:support" in firefox, it shows me these data:

    Data do driver 10-1-2013

    Data do driver (GPU #2) 11-12-2014

    Descrição do adaptador Intel(R) HD Graphics Family

    Descrição do adaptador (GPU #2) NVIDIA GeForce GT 750M

    Deslocamento/Zoom assíncrono none

    Direct2D ativo true

    DirectWrite ativo true (6.3.9600.17795)

    Drivers do adaptador igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32

    Drivers do adaptador (GPU #2) nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um

    GPU #2 ativa false

    ID do dispositivo 0x0a16

    ID do dispositivo (GPU #2) 0x0fe4

    ID do fornecedor 0x8086

    ID do fornecedor (GPU #2) 0x10de

    Janelas aceleradas pela GPU 1/1 Direct3D 11 (OMTC)

    RAM do adaptador Unknown

    RAM do adaptador (GPU #2) 2048

    Renderização WebGL Google Inc. -- ANGLE (Intel(R) HD Graphics Family Direct3D11 vs_5_0 ps_5_0)

    Subsys ID 05f61028

    Subsys ID (GPU #2) 05f61028

    Versão do driver 10.18.10.3316

    Versão do driver (GPU #2) 9.18.13.4475

    windowLayerManagerRemote true

    AzureCanvasBackend direct2d 1.1

    AzureContentBackend direct2d 1.1

    AzureFallbackCanvasBackend cairo

    AzureSkiaAccelerated 0

  • I guess it wouldn't be related to webgl if you can play other games using webgl in the browser.

    Can't really offer any suggestions without knowing/seeing what sort of events your game is using.

    Have you tried making a backup and stripping things out of the game to see if by removing anything it allows it to run?

    also, if you open the browser's console, are there any error messages?

  • No error message.

    The Firefox console just show:

    http://25.3.7.68/dev/jogos/games/RachaC ... L5/data.js 200 Ok 69ms c2runtime.js (line 83)

    The aba answer brings "null"

    So, the webgl works for this site http://www.firstpersontetris.com/ but not for this one https://www.scirra.com/demos/c2/renderperfgl/

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • you could try forcing webgl to work if you think it may be a webgl issue: https://wiki.mozilla.org/Blocklisting/B ... s_features

    "To force-enable WebGL, go to about:config and set webgl.force-enabled=true."

  • due to legal stuffs, for u to test the html5 files you need then to be on a host, like for example dropbox or google drive.

  • due to legal stuffs, for u to test the html5 files you need then to be on a host, like for example dropbox or google drive.

    Not if it is firefox. Cross-browser origin stuff should work fine offline in firefox.

  • Prominent, I had done that and did not work. It´s not a webgl problem.

    After few hours, I stripped the project and left just 2 lines and 5 objects. If I remove any of them the export works, otherwise, for a few firefox the screen keeps black.

    Resume:

    • Work perfect in preview (chrome and firefox)
    • after export for HTML5 it works in Chrome but not in "some" firefox
    • If i remove any line or any object from the project, it works <img src="{SMILIES_PATH}/icon_e_sad.gif" alt=":(" title="Sad">

    try the demo with Firefox and see if works for you:

    demo: http://www.kiduca.com.br/kiduca/jogos/g ... Construct/

    capx: https://dl.dropboxusercontent.com/u/943 ... teste.capx

    My firefox is v39.0

  • I was going to say that it's probably the Layout Transition plugin, but I see you just posted on that thread.

  • I tried the demo in firefox, and it works for me.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)