Healer's Quest restarting after a couple minutes of play (iOS only)

  • Hi everyone,

    Healer's Quest has released a couple months ago on iOS, but the game constantly crashes and restarts.

    At first I thought about a memory problem, which sounded weird as the game is running perfectly well on mid/low-end Android devices (mine is a Samsung A3 2016 (1.5Gb RAM)), while it crashed on iPhone 7 (2 Gb RAM).

    But anyway, I optimized the game just for iOS. After testing it was still crashing, so I optimized even more. Still crashing. I did tests removing nearly all character graphics (something I will never be able to push to the store because it's even not a game anymore), and even then, it's STILL crashing.

    I thought it could be the save game, or the fact of using both savegame and LocalStorage, so tried removing LocalStorage but it's not better. I even tried removing as much plugins as I could (Gamepad, GameCentre, Keyboard, Mouse, etc.) and all third-party plug-ins but really nothing helps. I tried adding a empty black screen between layout changes to let the game have the time to save before loading a new layout, but not better.

    Did anyone already have this problem or do you have any idea of what I could do?

    Please help, Healer's Quest rating on iOS is currently between 1.2 and 1.5 on every store as everyone complains about this bug and the game is just unplayable. I really would like to fix it but it seems impossible at this point.

    Thanks for your help!

  • I don't have an answer for you, but I would advise to temporarily close or pause appstore listing until you fix the bug.

    Then continue disabling and removing big parts of your project and see if it stops crashing, even if the game is not playable - remove saving/loading, effects, disable entire event sheets and groups etc. Once it stops crashing, try to narrow it down to a specific event or plugin.

    You can probably run the app in xcode simulator and get some logs which may help to find the problem:

    forums.coronalabs.com/topic/71294-how-to-see-xcode-simulator-log

  • Thanks for your reply, I'll try to see if there is something useful in the simulator.

  • dop2000

    I may have something!

    Any idea what this could be? I'm a bit lost...

    Thanks a lot!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Maybe an extra quote in the string?

  • Or this error message may be completely unrelated to your app.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)