Gamepad return value - is it me or is it a bug?

  • Dear all,

    Could someone with a Microsoft Gamepad please have a look at this : https://dl.dropboxusercontent.com/u/184657779/C2%20problems/gamepad%20axis%20raw%20value.capx?

    I am integrating a gamepad input control and had everything working as per the manual a week ago (then no testing during the week). Then unexpectedly I found that the controller had stopped working... A little investigation and it appears that the returned RawAxis value (for axis 0 and axis 1) is in the range 0 to 1 instead of 0 to 100. However, the returned Axis value is in the range 0 to 100, even though the only difference between them should be a null zone around the center....

    The only thing I've changed is I bought a genuine Microsoft gamepad to replace the rather shoddy and cheap one I had from ebay previously. On plugging it into my system, Windows updated its drivers... and I suspect that the problem might lie here. Before I go messing with my system, I would really appreciate a second look using r163 to see if it's a bug in C2 (slim chance I know, but I would like to eliminate it first) or to confirm the worst - that I will have to start uninstalling and reinstalling my drivers .

    Thanks!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • OK, here's a quick update: I've uninstalled /reinstalled the xbox360 driver and the error is still present....

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)