My game stopped showing ads. (Cocoon+MoPub+AdMob)

0 favourites
  • 2 posts
From the Asset Store
No Ad-Sharing, Fully Open Source, No Remote Control, Well maintained
  • Hey guys, I was wondering if anyone has a similar experience or could help me out. My game is in Google Play and was displaying ads regularly. This last week it started showing ads just some times, and now it came to a point where from 30 times I open the app I am lucky to get banners 1 time. AdMob seem to have a fill rate of 100%, yesterday it got requests 16 times and served 16 ads. In MoPub, the AdMob network seems to be running, and it is still working, (only rarely displaying 1 ad). I attached a screen shot. It gets my attention to see that when I run it in the CocoonJs Launcher it shows ads 100% of the time. So MoPub is capable of showing the ads. I really need your help, as you guys know not being able to display ads defeats the purpose of all this effort, and Crosswalk as you all must have experienced by now is not a serious alternative to publish for Android, at least not yet. Thank you for your kind help!

    Using compiler version 1.4.7 (Because the 2.0.0 Beta never displayed ads as you all know).

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Hi developmentcrew,

    I got this old topic since I have the same problem with my app published recently. The first days I got many impressions of advertisements but some days later, the app stopped showing ads. No updates were done in the app or new releases were published in the Play Store.

    I'm using C2 229 and build with Intel XDK 3400. The Admob plugin I'm using is Cordova Admob Plugin: cordova-plugin-ad-admob 1.0.107 by Sang Ki Kwon (Cranberrygame).

    I tried the next test: If I build a new version with other different package name, It looks start working again. But not if I use the same package name with a higher version number.

    Someone could help me with this? I have been for a long time trying many things without successs. I'm quite frustrated.

    Thanks so much!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)