Game exported with NW.js doesn't launch (preview with NW.js works)

  • Hi everyone,

    I have a problem with the NW.js exported version of my game Healer's Quest: it just doesn't launch at all. The game works great when previewed with NW.js in the editor, but once exported, nothing launches.

    More deatils:

    At first, I was using C2 r265 with an older version of NW.js, probably from around the end of 2018.

    When launched from Steam after uploading, I just got a thin red line in the HTML5 default launch screen and nothing else.

    When launched from my desktop, I had this error message:

    So I downloaded r267 and the latest NW.js version (from March 15th), and it's not better. Nothing launches at all, and no error messages are displayed.

    I tried the exported version on 2 different computers and had the same result.

    I tried 2 more things:

    1) I created a blank project with just a colored square and exported it. It worked.

    2) I exported an older version of Healer's Quest which has been succesfully build and uploaded and played on Steam in the past, and it DIDN'T work (game doesn't launch)

    So it seems like there has been some kind of regression from last year's ability to build with NW.js...

    Is it a known problem?

    Any solution to this?

    Oh and by the way... I absolutely need to publish this update on April 17th for the 1 year of the game's release, so it is quite urgent. ^^'

    Thanks in advance for any help or information!

  • Look for a folder with your game name in \Users\<your_user_name>\AppData\Local\ and delete it (or rename it). That should be the profile of the game.

  • Thanks for the suggestion Asmodean , but it sadly doesn't work.

    I tried:

    - Renaming the folder, then launch the game again

    - Renaming the newly created folder, then building again, then launching the newly created build

    - Deleting every folder then launching the newly created build

    None of the 3 works. :(

    The game will still not launch (not even a black screen, just nothing at all).

  • if you downloaded the new nwjs version and then returned to the old version, it will display the error message in the screenshot. but it should still work smoothly.

  • The game will still not launch (not even a black screen, just nothing at all).

    Try to delete the folder in \AppData\Local\ again. Restart your Computer and export your game again in a complete new folder don't export it in an old one.

    If you get at least a black screen again, try to press F12 for the develop tools, choose the tab 'console' and look if you have any errors.

  • Thanks for your help, Asmodean . I added you to the special thanks of the game.

    I did exactly what you said, and I'm not even getting a black screen on the win64 version. However, I launched the win32 version, got a black screen, hit F12 and got this:

    Looks like the problem comes from the plugin Steam4C2, and I'm investigating it.

    Hopefully I'll find a solution there.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • It looks like it's something missing. I would ask MadSpy orAJ2DI.

    Be aware that if you use a newer NWjs version for an update of your game, all people that bought it on Steam can also get trouble with the NWjs-profile. They have to delete the folder, or you rename the project or you handle it yourself with a batch-file or something like that. Maybe TheRealDannyyy has an idea about that.

  • Did you make sure that your NWjs version is supported by the plugin itself? Judging by the recent activity of the plugin developer (non-existent at this point), it's probably only supporting older versions.

    The profile thing is just an issue if you downgrade NWjs, which you should never do anyway. As already mentioned, creating a simple batch file to delete the profile folder should work.

  • Thanks for the replies, guys, and sorry for my long response time.

    You are both right, I've been able to solve the problem by getting back to an older NW.js version. The problem actually came from the Steam4C2 plugin.

    I got to get back to NW28 version actually. Just check the list of supported versions in the "your download" section if you get that problem too : scirra.com/store/downloads

    Thanks a lot!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)