Game Center doesn't work

0 favourites
  • 6 posts
From the Asset Store
five golem elements Sprites Sheet.Best for enemy or villain game characters.
  • So I have an app set up with Ejecta, followed the Ejecta Workflow tutorial, almost everything seems to be working just fine. However, the one thing apparently not functioning is the Game Center, in that it doesn't seem to show up at all. I've tried both "Soft Authenticate" and "Authenticate" commands, to little avail, and tried adding visual cues for the "On Authenticated" condition, just in case (these don't work, leading me to believe it's not authenticating at all). Likewise, the score leaderboard won't show up when it's supposed to. I've gone through the motions a few times, but can't seem to figure out what exactly is causing it. What might be wrong?

    I am testing the game on an iPad, if that helps.

  • Bump?

    Bit of an update: when trying to view the score leaderboards in one of the Xcode simulators, I get the message "Game Center unavailable/User not signed in". When running it on my iPad, I still get nothing. Is this normal? Does Game Center only show up once your app is published, even if you've already got the leaderboards set up? Perhaps I'm just missing something.

  • I have Game Center working with Ejecta on several games. It seems the Game Center function does not work at all with the simulator, you need to deploy to an actual device.

    The device need to be registered as a development device with the correct provisioning profiles installed.

    Make sure you are logged in to Game Center on the device as well, as this seems to help. Once the game starts, a soft authenticate will usually work, and the GC welcome notification should momentarily pop down from the top of the screen.

    One thing to check is that the app has the GameCenter capability added to the info.plist. This is done automatically by Xcode if you click the GameCenter slider in the 'Capability' tab.

    Of course you need to set up Game Center leaderboards in iTunes connect first, I guess you've already done that.

  • Hmm, I went over it and everything appears to check out. iPad is registered for development, logged into Game Center, Game Center capability is on (in fact Xcode fails to build unless it's on), and the leaderboards are set up. The ad banners seem to show up where and when they're supposed to, so the Ejecta object in C2 seems to be working. However, oddly enough still no notifications from Game Center when it's supposed to authenticate, and the leaderboards don't show up on request. Should the app show up in my list of games if I open Game Center on my iPad? Can this be some error with the Bundle ID or version number listed in Xcode/iTunes connect? They seem to match up fine...

    A while ago when I was trying to figure out Xcode, I had to go through the process of "revoking my iOS Developer certificate", which I thought wasn't supposed to be a big deal. It seemed to regenerate the certificates and provisions automatically and everything seems to be working peachy since then, but right now I'm really not sure what might be going on so I'm willing to blame anything.

    Thanks for any help.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • One other thing I can think of is to make sure you set your GameCenter account on your device for Sandbox mode, it's the only way I have gotten my game to work with GameCenter when testing.

  • Looks like sandbox mode was the problem. Thanks much!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)