fps slowdown in r158?

  • here's what fps I get loading the simple catapult example:

    Chrome:

    http://i.imgur.com/iWa9qwN.png

    Firefox:

    http://i.imgur.com/py8xUH4.png

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Ashley Anything New on whats actually causing the slowdown?

    I really was pulling my hair out thinking it was my computer.

    And for the people that say the slowdown is just for chrome,Im getting the same thing just a tad less lag with Firefox.

  • Uh oh, just went to "About Chrome" to see what version I have, and it's 31, but says "reboot to finish update" ack!

    OMG, that is horrible. I can now use Chrome to test how my games play on Iphone 4.

    http://hexedtext.clay.io/ is this playable??

    on my pc your game runs smooth on firefox but extremely slow on chrome (unless i resize the window to a very tiny dimension)

  • OK, I think this is to do with our detection of Swiftshader. Chrome has a software WebGL renderer (called Swiftshader) for the Windows version only, and it tends to be really slow. If the graphics card driver is blacklisted then it would use that for WebGL rendering instead of the GPU. When they first released this it was really annoying for us, because it would always use the WebGL renderer even if it was software rendered and the canvas2d renderer would be GPU accelerated. So we implemented a pretty nasty hack (it could have broken at any time) to detect Swiftshader and revert to canvas2d instead. I didn't know if that would be effective, since I thought if the driver was blacklisted then surely the canvas2d would be software rendered too. I guess this is not the case and canvas2d can often be GPU accelerated where the WebGL renderer is blacklisted and using a software renderer.

    Anyway in r153 we changelogged that the detection had changed. A Google developer announced that there was a new official option to avoid software-rendered WebGL (failIfMajorPerformanceCaveat). In the interest of avoiding ugly hacks and sticking to the official recommended way of doing things, we removed our own hack and started using that option instead. Turns out it's not actually supported in Chrome 32, and I've been told it should be in Chrome 33+. So until Chrome 33 all we've done is enable the software-rendered WebGL again. If you're affected, check the renderer string - I'd guess you were previously getting canvas2d and now you're getting WebGL.

    This would only affect Chrome on Windows where the driver is blacklisted and the CPU is not fast enough to software render at 60 FPS. So no mobile devices affected, no desktop systems other than Windows, no other browsers, and not even most Chrome users (judging by Mozilla's stats, since they're the only ones to publish blacklisting figures, about 20% of users have blacklisted WebGL support). And as soon as Chrome 33 comes out it should suddenly get faster again, since it understands the failIfMajorPerformanceCaveat setting and should switch back to GPU-powered canvas2d.

    I don't think we'll do another stable update for this - it's not a permanent problem, since even if you publish now, when Chrome 33 comes out it won't be slow any more, and only a minority of users using a specific OS + browser combination will be affected. I also don't see much point in fixing it for the next beta since by the time we make another stable release Chrome 33 should be out which will fix it anyway. In the mean time a workaround is to disable WebGL in project properties, or force Chrome to use GPU acceleration (go to chrome://flags/#ignore-gpu-blacklist and click Enable).

    tl;dr - temporary blip which should be gone soon

  • glad to hear this! :)

    and the temporary workaround works for me!

    thank you very much

  • Ashley Thank you so much!! it works! I am so happy that my computer was not the issue,I am having no issues with framerate now that i turned on WEBGL.Thank you once again!

  • Hello Ashley! I have the same problem with shinkan, but i afraid it a bit bigger.. After i updated Construct from 139 to the last version preview in Chrome become VERY SLOW. In Internet Explorer i can't start preview at all it give me few errors like: ""Javascript error!

    ?????? ?? ???????????? ??? ???????? ??? ?????

    localhost/preview_prelude.js line 145 (col undefinded)

    This is either a bug in Construct 2 or a problem in a third party plugin or behavior -

    please report it to the developer"

    In Mozilla Construct ask me to update it to last version, but it already the last version. I updated every browser, updated a drivers for video card, cleaned all with Ccleaner.. and nothing works =( Please help!

  • I downloaded Chrome 33beta and that seems to have fixed the slow-down problem I was having.. my game was running at 3fps, and is now back to 50-60fps

  • Definitely a Chrome 32 issue.

    1. chrome://flags/#ignore-gpu-blacklist

    2. Override software rendering list = Disable

    3. Restart Chrome

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)