Feeling salty

  • I just spent hours trying to get NWjs to work with my project on a fresh Windows install but it's just not happening. Tried C2 versions 217 to 221, tried nwjs 13 alpha 6 to beta 5, installed all drivers, disabled firewall, tried preview and export builds, tried 32-bit and 64-bit. It's all the same: No error message, no window, the nwjs process just sits there in task manager hogging memory. New projects work though, so something's obviously up with my capx. But what? And what can I do to fix it? Anyone else have the same thing happen to them before?

  • Export again and try this in the Win32 version:

    Rename "package.nw" to "package.nw.zip" and extract it to a folder called "Package.NW"

    Rename the game exe to "nw.exe"

    Are you using Greenworks plugins at all?

    Also, try putting all the plugins and behaviors you use into the New Project for testing (one at a time to see when the crash happens).

    Hope that helps!

  • Thanks for the reply

    Export again and try this in the Win32 version:

    Rename "package.nw" to "package.nw.zip" and extract it to a folder called "Package.NW"

    Rename the game exe to "nw.exe"

    Tried it. Didn't work.

    [quote:5nzn3ngy]

    Are you using Greenworks plugins at all?

    Nope.

    [quote:5nzn3ngy]

    Also, try putting all the plugins and behaviors you use into the New Project for testing (one at a time to see when the crash happens).

    Didn't make a difference either. Very strange. I'll try to strip the capx down to a bare-bones version and see how that goes next.

    Btw, the project works fine in Chrome and used to work fine on the old Windows install.

  • Did you install directx?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I did. Tested a little and it seems to work fine on other machines. I guess the Win install got borked somehow. Re-installing...

  • In the exported folder there is a debug.log file. Does it have any errors?

  • This is what I get from x86 and x64 builds both before and after killing the nw.exe processes in task manager:

    [0210/030956:INFO:nw_package.cc(175)] "D:\Users\Erik\Desktop\Prototype\win32\nw.exe"

    [0210/031229:INFO:nw_package.cc(175)] "D:\Users\Erik\Desktop\Prototype\win64\nw.exe"

    Maybe that's an error code of some kind? Doesn't look like it though.

    Rambletime: The special coddling that NWjs requires to get going man... Lag spikes that come and go, demands fresh gfx drivers at all times, doesn't like integrated gfx chips, doesn't like Optimus, doesn't like Macs or Linux OS'es, doesn't like recording software, etc etc...

  • Yeah, that's not an error. Hmm, It's puzzling why the window doesn't show.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)