Facebook and R117

0 favourites
  • 4 posts
  • haven't tried it with any other versions but is anyone getting the following error when previewing their games *ONLY* when you haven't checked keep me logged in on Facebook ?

    JavaScript Error!

    Unable to get property 'UserID' of undefined or null reference

    connect.facebook.net/en_US/all.js, line 75 (col 1303)

    This is ether a bug in Construct 2 or a problem in a third party plugin or

    behavior, please report it to the developer!

    I'm using no plugins or behaviors other than what come with the default project when you choose create new and choose the Facebook project.

    no graphics no sprite.

    file -> new -> new Facebook project the second I run it I get that error. I have provided my app id if you click refresh it doesn't popup and then it works. If your already logged into Facebook it also doesn't happen

    hopefully someone knows how to fix this because if I can get this thing to work I'll definitely be buying a license my game will need waaaaaaay more than 100 events eventually but right now I'm learning and experimenting so using the free version

  • As R117 is a beta release, you may want to try the last stable build which was R114

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • There are a lot of what Facebook calls breaking changes that are not compatible with the c2 facebook plugin. More so by the week. So it's completely possible that this is the result of that but I'm guessing it's more something you didn't do right with your app. Did you add a login button or set the user to force a login action? Without having a user click login it is very limited in what you can fetch for info on them.

  • your not understanding the issue, so let me shorten it

    The plugin is working I can get the Facebook name full name and id after login in the game.

    its when the game *FIRST* loads after hitting F5 if your *NOT* set on Facebook to auto login. if you click browser refresh all works fine. seems to be *ONLY* when running in preview mode. I loaded it up and connected via another lan computer and no issue at all.

    not sure if when in preview mode (pressing F5) its loading the browser too fast or what.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)