Export not working

0 favourites
  • 7 posts
  • I tried exporting on rc81 and got the error they mentioned but the log() fix didnot work for me. I have also tried on r82 with no luck. I am exporting the tutorial game to an apache server and I tried adding mime types in htaccess and several browsers. I keep getting javascript errors, the latest being unintended identifier in line 5179.

    Basically, I need an HTML5 design program for a project and so far I can't export anything working out of this one. I understand that other people's projects work so I asssume I am doing/not doing something.

  • When you have installed r82, have you uninstalled r81 as suggested during install?

    If have not done this, it could be that there are old files been used that have the error.

    It would also be helpful, if you can tell us what javascript error comes up (there can be so much). Another way we could be able to help you is when you give an URL to your project. If you do this, it is the easiest to find the error if you compile without the minimizing of the scripts.

  • Can you tell us what the exact error message is and what line 5179 is?

  • Here is the URL so you can see what I am getting:


    All I did was export and transfer the files to the server. I did some minor troubleshooting and the script is running and it stops on:



    cr is not defined


    sysexps.log10 = function(ret, x)

    Uncaught SyntaxError: Unexpected identifier


            ret.set_float(Math.//log(x) / Math.LN10);


    Tested in Chrome, IE 9 has the same issues.

  • That code has somehow been modified, compare yours above to the actual code in the C2 source below:

    ret.set_float(Math.//log(x) / Math.LN10);

    ret.set_float(Math.log(x) / Math.LN10);

    It's causing a syntax error because there are two slashes in there (//) that shouldn't be there. I have no idea how that could end up there! Are you sure you haven't modified some source files somewhere? Perhaps you did a find-replace for log that also affected that function?

    Edit: also you did not upload c2runtime.js in your link, this URL is a 404: http://facebookgametime.com/game/c2runtime.js

  • I thought I had already replied to this, but just in case, I wanted to let you know it was server related. For some reason it was adding the extra / in the code. Never seen that before, tried another server, works great! Thanks for the help!

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • That's weird! Glad to hear it's resolved though.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)