Is this what I can expect?

0 favourites
  • 13 posts
  • Ok, so I purchased C2 and got my project completed and it works fine. You can take a look at a demo version at: I'm personally impressed. It didn't take me ages and it works!

    So next I decide to put this on the Chrome Web Store. Well, that's 2 days work of work that turned into a failure. My app just gives me a blank stare when I click on a purchase button. Why? Ashley say it may be in the IAP so until he gets a chance to look at why isn't working, my Web Store app is in limbo... unpublished.

    Ok, so while I wait for the next update to C2, I'll look elsewhere. I decide to take a look at publishing on Amazon. Well, that's a failure too. I decided on a standalone rather than a hosted app because I'm not yet ready to shell out the cost of an https server. So, I go through the whole process of getting my app ready to publish, resizing and uploading graphics, reworking some code for the IAP, typing in descriptions, uploading the .zip... It looks done. But, I want to test out the IAP in Amazon before I unleash this on the unsuspecting public, right? Hey, it didn't work in Google so let's make sure. Nope. Since I'm writing this on a Windows machine and apparently Amazon apps only work on Android devices (unlike Google which takes an HTML5 app), I need an .apk. Well, I don't have an apk, I exported it to Amazon, which is HTML5 zipped up. They had no problem taking my .zip file but now they tell me, in order to test it, I need an .apk. Well, they're going to turn it into an APK anyway, why not let me see if it works first??? Oh, nevermind.

    Whatever. Time to learn XKD so I can get an .apk... So here I go through the process of exporting my app to Cordova and creating a new project in XDK. Hey, it loaded it... great! Ummm not. When I run the emulator, most of the time the buttons at the top left... simply vanish. I get my blue menu bar and my logo, but no buttons. Sometimes, I do see them when I punch the reload the app button a bunch of times... and they work, when I see them. But, when I click on the one that opens an external website (where my app's help is located), XDK gives me some error about calling a Cordova plugin who's native code is not known to this emulator. Whut? It's a browser plugin. How can that not be native??? Is it alien???

    Ok, let's figure out why the buttons aren't showing up all the time, we'll get to the thingy later. I discovered that if I kept hitting the "reload app" button in XDK that it eventually shows my buttons. Ok, maybe this has something to do with the stupid XDK splash screen showing instead of my splash screen. So what are those instructions I see on how to get rid of it? Wait, they're showing me java... intel.xdk.device.hideSplashScreen(). Stoopid XDK, why are you telling me this? I'm creating this in C2. I don't code in java. I dunno even where to begin putting that. Let's click some more on the refresh. Oh, now I have something new that just popped up... unexpected call to process.exit(). Whut? I didn't tell anything to exit. Reload again... unexpected call to process.exit(). Holy......

    Ok, fine..... I'll delete the entire project and reload the export... ummm no, I won't. Error creating project: Import directory contains Intel XDK files. Well no kidding it contains XDK files. I exported it so I could load it into XDK. What kind of files did you expect to find there? Commodore 64? What kind of stupid error is that????

    OOOOHHHH KAY... I'll just delete the entire Cordova export directory and re-export from C2... right? Wrong. I try to delete the files and apparently XDK has changed the permissions. What? WHY? It's my stinking computer, why do YOU need to change permissions????

    Ok... restart my file manager with admin privileges... and now I'll delete your stupid privileged files. Hah! Screw you Intel, files deleted! Now, reexport from C2... screw the emulation... let's just go build this thing and get my .apk... right? Sure.

    Wait? You turned a 500k project into two zip files that are 48 MB??? Well that explains a lot. If the code in their chips is this bloated it's a wonder we're still not on 8086's. We'd be at quantum computing speeds if they'd learn how to code properly.

    Next up.... trying to get this monstrous .apk over to my Android phone having never done that before. Oh wait, the battery is dead...

    So my question is... will I ever get this thing published? I'm certainly not happy with this process thus far.

  • If you were to go the Cocoon route you would have to get rid of all dom elements, that's ok for games, crap for apps.

    Anyway yeah there is a fair amount of hair pulling, just like you have in all the others.

  • I'm sorry. Paying them some cash for a monthly service... I could see that. Shelling out $500 BUCKS to remove THEIR splash screen? Outrageous. I am NOT an advertising agency for their service! That's not providing a service for a fee, that's greed.

    This whole process of getting a C2 project out the door needs to be a LOT less difficult. Right now, I feel like I've been taking an express flight to Paris, got pitched out of the plane somewhere in the Azores with no parachute... and there's no connecting flights going to Paris.

  • Oh, and here's a great one. I got one of those massive .apk files loaded into Amazon for testing. It immediately warned me that it had detected the Google IAP... Well that's damned funny since Google didn't detect it. What's even funnier is that you don't see your app running. They perform all these tests and you have to somehow guess as to whether it looks and works ok.


    ok... ok... so if I want to make Amazon happy, can I just delete this: <script src="cws-buy.js"></script> from the index.html and remove that .js from the project?????

  • There's tons of warnings for all stores, most are benign, if it won't let you use a Scirra plug, then that's a bug.

    You shouldn't need to delete anything done by C2.

    Unless it's something in the manifest.

  • In defense of Cocoon. Um, I know that the Splash Removal Screen price is crazy but the performance that comes with Canvas+ is quite good....

  • I don't see how you get all these errors and problems. Maybe you just had a bad day. I managed to publish my game to Google Play and on Amazon with a little learning of how to use the Intel XDK. I suggest, let it rest for a day and try to figure out what causes these problems. If you do it frustrated you'll just end up more angry.

  • Ah, no worries. I've had plenty of time to cool off. I've been sitting here the past 30 minutes waiting for the awe inspiring Intel 'Cloud' to build my app. Who needs to take a break when you have XDK to put a cork in things?

    In defense of Cocoon. Um, I know that the Splash Removal Screen price is crazy but the performance that comes with Canvas+ is quite good....

    I'm making an app. Performance isn't exactly an issue. Getting the damned thing published SOMEWHERE without paying a fortune is...

  • Ya, thanks. I was gonna get to that eventually. But if I can't even get something out the door with Google or Amazon...

  • There's tons of warnings for all stores, most are benign, if it won't let you use a Scirra plug, then that's a bug.

    You shouldn't need to delete anything done by C2.

    Unless it's something in the manifest.

    Thanks, that at least takes rooting through the export files off the list. As you can see from my first post, I've been at this almost 8 hours now after my rant, trying to get even an Android build on Google play... still... nada. Now, XDK is refusing to build and giving me no exact reason.

  • Does it tell you an error message?

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Yea, it was some file missing but didn't specify which. I just re-exported from c2 and it worked.

    Finally, got an alpha started on Google Play. Took me over an hour to get it downloaded onto my Android device though. That was another headache I won't detail. But it amused me when I tried to test the IAP and it said, oh, you can't buy this... you're the publisher.

    I guess my point is this: I'm pretty well versed in computers (35+ years of using, repairing, building and programming them) so it's not like I'm a total novice. If I'm having these kinds of issues, this much difficulty, in getting an app published, how much frustration do those who have no programming skill and buy C2 thinking it's going to be easy, go through?

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)