What exactly causes THIS to happen?

  • This didn't happen to me until just a few minutes ago. I'm making a large scale sprite, putting in small details to make it look nice. I exit the sprite editor to save the project. After saving I opened the sprite editor back up, and tried zooming back in into the sprite. The sprite vanished, so I zoomed out, it came back. I can't zoom into large sprites, they seem to vanish. Is this fixable?

  • You can have a look at your graphics drivers, update them if an update is available. A lot of glitches are caused by this issue.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • What C2 version are you using?

  • It's a driver issue. I get it with my ati radeon x1200 card in C2's editor with the latest driver. Hopefully you have a newer card that can use a newer driver. Power of two textures display correctly at any size in C2's editor for me. The issue doesn't occur at export at all.

    As an amateur opengl programmer I'd guess it's a mip mapping issue with the textures. Maybe you could tinker with the mipmapping settings for your driver? I posted a possible coding solution before that I've used in another project, but when ashley tried it the result had no effect on my end. In the end it may be some other obscure driver bug causing it or something.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)