Crosswalk Intel XDK experiences

  • ok, I'm lost in that new XDK UI.

    Can someone please explain few things:

    • what's the difference between "Core Cordova Plugins" and "Intel XDK Cordova Plugins"? Which one should I use?
    • Minimum and Target Android Version?
    • what crosswalk versions are for stable and beta currently in XDK?

    Did something changed between C2 and XDK? Cause I can't build any project witch android crosswalk through XDK

    It only gives me "The build failed. An error occurred while building the application. Verify your build assets are correct and try again."

    Why everything that used to work nice and smooth must always get complicated and irritating?!

  • shinkan

    i'm getting the same error

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • DARTH Crusher

    I get this with C2 completely new project with only one sprite in the middle

  • Hmm same issue here. It's a bit more complicated now. I thought it was related to the launch icons and splashscreens, but I set them and it still failed :S

  • Ah, I was about to post the same issue. I'm just about to finish wrapping up a little app but when it came to building, I've been struck with the same issues. Neither emulation nor building works, at all. When uploading, the zipping and uploading process is far too quick. It's like the assets aren't even there.

    Would really appreciate a quick response on this from the Intel or C2 team.

    EDIT: Just tested now with using one of the demo files instead of starting with a blank file, and it seems to work fine. I guess the blank template is just missing a file or something.

    Nope, wait, it's not working. The emulator works for the most part but throws up errors often. It now uploads the whole project but again refuses to actually build the project, saying that assets are missing. I've gone through the project settings and put in icon files and unchecked all the unnecessary plugins, but it still isn't working.

    Two updates: I've gotten emulation working with the blank template. Files need to be copied to the "www" folder, instead of the root of the application. I haven't used XDK in a while so I'm not sure if it was just me being an idiot and not knowing that.

    Second, regular Android app building works, but Crosswalk doesn't. This isn't immediately helpful but might help someone figure out what's causing this issue.

  • Guys i am REALLY desperate to put admob ads on my applications.. i got a shot of working in a company, but to do so i need the ads working.. Did anyone have made it? i also try the ludei via mopub, but still no work..

    i really need this to work over intel xdk..

  • Anyone got problems with browser commands with the new XDK?

    i have a button for browser-close and another for opening a url in a new window, both of them stopped working in the latest version.

    I have in app browser permission enabled, am i missing something else??

  • Ashley Could you explain to us why the XDK is not working? It seems like im having the same issue as everyone else,i cant seem to get an app to build the correct way using the XDK.

  • Compiling etc works without a prob for me. But the app is not in fullscreen anymore, even though i ticked that option. Am I missing something?

  • shinkan Did you figure out how to fix the intel xdk issue? I cant really figure out how to get this to work right.

    I also agree with you,Why would they change something that is perfect and make it even harder for people to understand.The UI was fine now its just horrible and confusing with no information on how or what is what.

    Please send me a msg if you find a fix i really need to build my project.

  • there is a fullscreen option in the android tab and also in the crosswalk tab, make sure you checked the crosswalk one, that goes for all the other settings.

    my apps runs and compile fine, in full screen with audio and everything, i just can't perform browser actions.

  • if you cant use browser actions how would you exit your app?

  • are you able to post all your settings you use in the Intel XDK Crosswalk build please? I've tried with a blank project and it still says build assets fail error, same as the others.

    The upload of my project zipping files is super quick, seems to not be uploading properly or something :S

  • DevDan thats a good idea,It would be cool if we can get anyone show us the New way to build our app.

  • I didn't change much.

    In the permission tab i have only:

    In app browser and splash-screen enabled (but previous exports with more permission worked as well, so i don't your problem is there)

    In the build tab under android-crosswalk:

    I filled in the normal values for app id/name/desc etc.

    The app version and version code i had to change on the second export so google play will let me upload the file.

    Domain access i left with *

    and cli version with 3.3

    I checked the full screen box

    orientation: landscape

    install location: default

    i check the signed box

    and i used crosswalk beta

    I also uploaded icons and splash screen images (all images must be located inside the www directory of the project before selecting them.

    That's it.

    As for exiting the app with the back button, that's another strange thing, it exits with the back button regardless to any events calling it, i think it's something new and built-in xdk, i have only one layout in this project, so i don't have any events to switch layouts on back button or anything, but i believe if i did, it would close the app as well, which is not a good thing at all...

    Just to make it clear, i have an event on back button/touch sprite - browser close.

    This event only works if var canPlay = 0

    but it closes the apps even when this var is = 1

    I hope this helps you guys.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)