Create Object won't work. (Solved)

0 favourites
  • 5 posts
From the Asset Store
Fully commented source code/event sheet & sprites to create a space shooter game
  • I have a sprite in my project that is very large. If there is only one on the layout, I can create a second one in-game perfectly fine. But if there's more than one on the layout, suddenly the Create Object function refuses to create more even if I destroy all of them. If I want to create a smaller object however, it works.

    Is this a bug or a general limitation in Construct 2? I'm using the free version.

    EDIT: Hold the phone. I spontaneously fixed it. Apparently the problem was the fact that the additional copies (but not the original) on the layout were set to be invisible at the start of the game (so they wouldn't be seen). I guess somehow this must've confused Construct and perhaps caused all the newly created ones to be invisible too.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Here are the issues:

    1. You are providing too little information.

    2. If you think this is a bug, you should report here: and follow the guideline strictly.

    3. Please be more specific about the sprite size you are using.

    4. Show us your events or perhaps even .capx file, so we can investigate more properly.

    Dear Admin and Moderator, please move this to the correct forums.

  • Fortunately I managed to fix it, so sorry for wasting your time. ^^"

    EDIT: Exactly what would the correct forum section be? I considered "How do I", but that seemed to be more for questions and tutorials on how to achieve things rather than troubleshooting.

  • By writing your title "Create Object won't work", that already implied that you claimed you found that a functionality in C2 does not work. That should be under bug forums.

    "How do I" forums is more like for asking, how can I do this or how can I use this function, or asking for clarification from the manual. :)

  • Oh I see. It's just that I didn't know if it actually was a bug or a mistake on my part (turns out it was the latter), and I didn't want to seem presumptuous. ^^"

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)