Construct 2 games do not work in Google Chrome

  • I have problems running Construct 2 games on Google Chrome.

    I developed a simple game with the free editon of Construct 2. The game works correctly in the preview mode inside Construct 2. When I export it as HTML5 application the game works no more. I uploaded on a web page and tried to load it online but it is not working (crash after loading). However it works correctly with Safari and Firefox.

    The same happens with every game on Scirra Arcade: they work with Safari and Firefox but not with Google Chrome.

    I tried with another PC and the same thing happens.

    Any solution?

  • hi bsi73it, the free version only support export to some platforms, did you try running the game incognito mode?

  • My game work's fine on chrome.

    Did you mean after uploading your game it's run fine on firefox?

  • bsi73it make sure your version of chrome is updated and then also update your GFX drivers

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • What is the incognito mode? How can I set it?

    The game has been exported to HTML5 and uploaded on-line. it works on Firefox and Safari but not on Chrome (it crashes at beginning after loading, this also happens with the other games in Scirra Arcade).

    The Chrome browser has been updated just 1-2 days before testing the game. I do not know how to update the GFX drivers (the video card is not very recent as is the PC (512MB RAM , Windows XP SP3) and the video drivers are not updated since some years. However the same thing happens (also with the Scirra arcade games) on a newer PC with Windows 7.

  • hi bsi73it, can you provide the link to where you are uploading your file, i would like to test it from my end, in the mean time maybe you can try creating or using another account on the same machine you are using, it might be some kind of user profile corruption.

    humbly

  • Most of the time the problem is you just forgot to upload one of the files and it gets a 404 Not Found error while trying to load the game. You can check for this in the browser console. Press Ctrl+Shift+J to open it.

  • bsi73it

    If you ever want to run something (a link, for example) in incognito mode, just right-click on the link and select "Open link in incognito window"

    It's just one of those wacky google-chrome-only-things.

  • The problem was solved. I de-selected the Chrome option "use acceleration when available" and now works correctly. Maybe it is a WEBGL problem with my video card.

    However there is also another problem. When I test it on my tablet (android 4.1) the game works but with no sound.

  • Ashley

    I've also started facing the same error for my game - it works fine in Firefox, and used to work in Chrome, but does not anymore:

    http://www.kongregate.com/games/cre80ve/moving-mazes

    I've tried all the suggested workarounds:

    * Have added exceptions for Kongregate to allow cookies

    * Have set local storage to on in Chrome settings

    * Tried disabling acceleration

    * Also tried it in incognito mode

    But nothing seems to work. Did something break in the recent versions of Chrome!? Please help.

    The game otherwise works fine on all platforms, including Android, Amazon and iOS (through CocoonJS).

  • exertia: Consider re exporting from a recent version and upload again on newground.

    Some old version of Chrome did broke stuff.

    Otherwise, consider checking your browser for errors.

  • exertia - it just gets stuck with the loading bar at 100% here, with no errors in the console. Please report all issues to the Bugs forum following all the guidelines or it is impossible for us to do anything about it.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)