Construct Editor not working properly, help?

0 favourites
  • 13 posts
From the Asset Store
Game with complete Source-Code (Construct 3 / .c3p) + HTML5 Exported.
  • Just bought the personal edition of Construct 2. However, the editor window for my layouts are not working correctly. I can click between event sheets and they will show up no problem. When I click on one of my layouts so I can edit what is in there, it still shows the event sheet. I can click around on the different objects on my layout, but I can't see anything. Any fix for this? Is it something wrong with my computer? Never had this issue when I used the Free Edition. I've tried restarting construct, reinstalling construct, and restarting my computer.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Do you have issues with all projects, even the built-in examples/templates?

    If it's just this one particular project, then it would be quicker to upload it for us to check.

    Have you tried 'File/Preferences/Reset dialogs'?

    If still no good, you may need to show us a screenshot of the problem because it is difficult to visualize what the issue is otherwise.

    BTW the license has no effect on the program other than allowing/unlocking features.

    Also what version of C2 are you using?

  • Just this one particular project. All of my other projects and example projects work fine. But when I was working on it at my school library on their computers, it was working just fine.

    I just tried resetting dialogs but it didn't fix the issue.

    I was using the most recent stable version from January and was having problems. Tried updating to one of the newer releases but still having issues.

    I'll upload screenshots and the .caproj here in a second.

  • Link to screenshot - ... sp=sharing

    As you can see in the screenshot, I have my "Game" layout selected so it should be showing that, but it just keeps showing the event sheet that I was previously on.

    Link to project file - ... sp=sharing

  • What happens if you click on the 'Game' Layout in the top right 'Project' pane?

    BTW just uploading the .caproj is no good as it doesn't contain the whole project.

    You will need to 'Save As' and select single project .capx.

  • It does the same thing as when I click on the top. I can switch between event sheets but I can't switch between layouts, at least visually anyway. It's weird because it does open the layout and I can click in the window, move objects around and create new objects, but I just can't see anything. My guess is my computer doesn't like how many events or objects I have, but I have a gaming laptop so I feel like it should be able to handle it no problem.

  • Ahh Sorry about that, here's the .capx - ... sp=sharing

  • Sounds like a video driver issue.

  • Sounds like a video driver issue.

    That was my first idea as well. Try updating your video card drivers.

    Ahh Sorry about that, here's the .capx - ... sp=sharing

    I downloaded your capx and opened it in r225. It works fine for me, I can easily switch between event sheets and different layouts. Just in case, I did a re-save and uploaded it: ... esave.capx

    You may try this on your computer, I changed nothing, but I doubt that just a re-save can fix this issue.

  • Yeah the re-save didn't fix it, but I will definitely try updating my video card drivers

  • Tried updating my video drivers, still not working properly.

  • I got it working! So I had both the intel graphics driver and the nvidia driver enabled and Construct didn't like that. I disabled the intel driver and now it works fine with the nvidia driver. Thanks everybody!

  • Good to know that this can cause a problem like that. Thanks for the heads up.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)