Construct crashes immediately upon loading event sheets

0 favourites
From the Asset Store
Casino? money? who knows? but the target is the same!
  • So a major problem has just hit me when working. I tried to open the caproj file today for my game, but C2 constantly crashes when trying to load the event sheets. I fear that they may have ended up corrupted when I saved yesterday. However this same issue is happening with older project folders I haven't touched in months, and that were working just fine until yesterday. I'm able to open super small projects, but Klang's not budging. I get no error messages. Construct simply crashes...

    I did some tests playing around with the XML files to find the source, but I can't seem to pinpoint to anything proving that the project files' corrupt.

    I also tried reinstalling construct. No luck...

    Has there been any super minor update that hit steam yesterday? I'm using version r216.

    This is freaking me out right now....

  • If you are using steam, can you download the standalone version from HERE and install in a separate folder?.

    At least you will be able to test your .capx (note: you can load any .capx in the standalone free version, but you just can't edit if over the free version restrictions).

  • zenox98 Actually I just installed construct on a different PC and loaded the project. Works just fine there. At least I now know it's nothing wrong with the construct project.

    Edit: Also tried installing the free version on my main PC. Same issue.

  • Can you share a .capx that crashes when loading?

    Are your graphics drivers up to date?

  • Ashley I can yeah, but you'll have to be comfortable with it being around 800mb.

    I also updated the GPU drivers for the sake of testing. Same issue. I'm using a GTX 970 (which worked fine until yesterday). The PC I made it work on is using a GTX 580.

  • We had same problem couple of weeks ago, after my mate did regclean. New projects where starting fine, bout couldn't load the old one. That was on win7 i believe. Game was saved earlier on win 8.1 but when I tried it, it did open at first. Anyway we switched laptops and it worked on other system which was win10 i think.

  • I've got a GTX 970 and haven't come across such an issue, but then I haven't updated for a couple of WHQLs - I like to wait for stability before upgrading - new drivers can still cause problems.

    Have you got a - much smaller - .capx that we can try and you're not bothered about sharing?

    Does it crash on the built-in examples?

    Any non-standard addons?

  • zenox98 It only happens on my Klang projects (even the ones that are several months old and were definately working). I'm also not super comfortable sharing capx's of my game since it's almost complete. That it's huge doesn't help either.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Understood.

    The only suggestion I have is to maybe make a new backup and try a little investigative hacking. Maybe start with chopping graphics by replacing with tiny substitutes, to see if it's a memory issue.

    Have you tried unticking the 'Cache icons in Editor' option in the 'Preferences/Misc' tab?

  • zenox98 Unticking cache actually worked! Love you man!

  • zenox98 Unticking cache actually worked! Love you man!

    errrr steady now ;/

  • zenox98 Unticking cache actually worked! Love you man!

    Good news!

  • Wow, 800mb compressed? I was going to suggest that you were just running out of memory... but if disabling the icon cache fixes it, that's the Windows limit of 10,000 graphics objects per process

  • Ashley That still doesn't know why it worked on the inferior computer just fine (which was nealy reformated), but not on the main setup. A conflict with cache or pre-saved data sounds more legit. Construct uses roughly 1gb of ram when working on Klang.

  • I don't know about one compute vs another, but don't worry--you're not the only one who must run their project with the cache unticked I can open it last I tried, but it will soon run into massive problems. The downside is the editor is slower without the cache, but that's still quicker than reloading regularly.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)