Cocoon Issues

  • ludei, I have only a little question, do we have the possibility to use the Compile on August? <img src="smileys/smiley1.gif" border="0" align="middle" /> And What's the future price like?

    Sorry to buther you now, but I'm really interessed with this, we are going to export our projet in one mouth and my boss said it's not so convinient to wait until compile came out. But you know, I really like cocoon

  • for me, cocoonj have 2 problems:

    1)I can't mute or set the sound to silent.(or change the volume)

    2)unlike app mobi, it can't lock the orientation and prevent auto-rotation.

    If this 2 get fix I believe cocoon would be perfect for me.

    ludei

  • ZhaoYun The audio volume issue, we do define the audio.volume property. That should be enough to change the volume.

    As for the orientation lock, we fully support it. In the launcher you just have to select the orientation in the settings panel (gear icon on the top right), and in the cloud system you have a set of checkboxes to select what orientations you want to allow.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • ludei

    thanks for replying

    audio issue: errr, I am not a programmer (thats why I use construct 2), so all I can tell you is construct 2's mute action don't translate to cocoonjs audio mute.

    orientation lock:

    I see what you mean, cocoonJS launcher has only portrait vs landscape, so I can't prevent the portrait to rotate upside down, however, the cloud compilation system does have the option to disallow upside down portrait~

  • ZhaoYun Regarding your audio issue it looks like Ashley will probably need to update the Cocoonjs plugin to add support for the new features.

  • , I see, thanks for the explanation, In the meanwhile I will work my way around by using stop music and don't play music.

  • After days of experimenting, countless exporting, this is my conclusion of how construct2 audio commands works(or dont works) in CocoonJ.

    This is it:

    audio silence-prevent music from starting, but does not stop them if they are already in played. (means you are never going to stop your looping music, but works well on sfx)

    mute- does not work at all. Music still continues plays, and will keep on starting to play. (Works well in preview, exported to cocoonj = fail)

    However...

    unmute will and can cancel out the audio silence of the tagged audio.

    eg:

    set audio tag "BGM": always unmute

    set audio silence.

    result= BGM ignores audio silence

    The bgm that is playing will continues to play, but new bgm wont start.

    Other sounds wont start. but playing sound will continue to play.

    Hope someone check if my findings were correct. and if it is so, please do fix/update it. =)

    ludei Ashley

  • Came across this thread looking to see if anyone else has had experience using CocoonJS and AJAX commands through Construct2.

    Ajax appears not to work through Cocoon and I was wonder if anyone hopefully knew a work around? Thanks

  • Came across this thread looking to see if anyone else has had experience using CocoonJS and AJAX commands through Construct2.

    Ajax appears not to work through Cocoon and I was wonder if anyone hopefully knew a work around? Thanks

    Someone told me XMLHttpRequests might be a viable work around for AJAX in CocoonJS. Can anyone verify?

  • After days of experimenting, countless exporting, this is my conclusion of how construct2 audio commands works(or dont works) in CocoonJ.

    This is it:

    audio silence-prevent music from starting, but does not stop them if they are already in played. (means you are never going to stop your looping music, but works well on sfx)

    mute- does not work at all. Music still continues plays, and will keep on starting to play. (Works well in preview, exported to cocoonj = fail)

    However...

    unmute will and can cancel out the audio silence of the tagged audio.

    eg:

    set audio tag "BGM": always unmute

    set audio silence.

    result= BGM ignores audio silence

    The bgm that is playing will continues to play, but new bgm wont start.

    Other sounds wont start. but playing sound will continue to play.

    Hope someone check if my findings were correct. and if it is so, please do fix/update it. =)

    ludei Ashley

    Found the same issues without reading this post, in an identical case (Sounds/Music in Construct Preview Work as expected, Sounds/Music in CocoonJS Launcher don't). Now I read your findings and are exactly the same, which means that it is still a problem.

  • Is Coccoon likely to support setting sounds muted in the near future or do I need to change my code?

    It works perfectly on a browser and it would be such a shame to have to re-write it.....

    Thanks

  • Ashley yeah, using the 'silent' command is the only audio issue I am having now using CocoonJS for ipad or android, with the latest beta Construct build. Is this something Ludei needs to fix, and so they know about it? It sounds like this has been a long time issue. Looping sounds will 'stop' but seem unaffected by 'silent'.

  • It's something Ludei need to fix, best get in touch with them about it.

  • Hi Guys,

    So: re the sound issue - from what I gather it simply doesn't work at the moment. Do you know if starting/stopping music/sounds will cause crashes in themselves?

    I've just started porting a game over to CJS, and get a few crashes - I've narrowed it down to it possibly being because I stop a music track, but haven't found out for sure yet.

  • Anyone got updates on this?

    I've used the following workaround: To give the repeating music different tags, and set volume to -1000db.. which works like a mute.... on most stereos! :)

    But I guess this is impacting performance since all the sounds are playing simultaneously, I would really prefer to be able to stop a sound.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)