chrome audio play at position causes jank

  • Just for everyone's information - there is a bug in Chromium engine where a sound played at a position (to give a stereo effect) causes a huge jank the first time it is played. I have created a bug report in chrome here as this is not directly a c2 problem; the problem appears on Chrome and nw.js...

    To work around it, play a quiet sound at an object during your start/splash screen and all should be well thereafter. I'll post here when the problem is resolved.

  • I get this in Edge, too, so I just assumed it was loading in the more advanced audio features as needed. But, yeah, my workaround has also been to just play a silent sound at the start of the game when it's not noticeable.

  • C-7 - ooooh - I couldn't get it to happen in Edge. I submitted a bug report (here) but it was closed because it appeared to be a chromium only problem. Are you able to create a capx - perhaps it is a c2 problem...?

  • Ashley, could you please clarify whether or not the play sound at position is a web audio call and whether - if it is web audio - this sound induced jank is consequently a bug in chromium? Please take a quick look at the chromium bug report linked in the first post - I sense that this will not get fixed from comments so far, and I don't understand the c2 internals well enough to argue accurately. Thanks.

  • Asley, could you please clarify whether or not the play sound at position is a web audio call and whether - if it is web audio - this sound induced jank is consequently a bug in chromium? Please take a quick look at the chromium bug report linked in the first post - I sense that this will not get fixed from comments so far, and I don't understand the c2 internals well enough to argue accurately. Thanks.

    You misspelled his name. That way he won't see your tagging. https://www.scirra.com/users/asley

  • Thanks glerikud - this demonstrating my inability to use my phone properly! Ashley - re-tagged in case my edit above doesn't do the trick. Thanks.

  • I commented on the bug report, but it wouldn't surprise me if they didn't fix it. It's a fairly minor issue with an easy workaround.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Cool. Happy that we tried and at least this thread will serve as a record for anyone searching about this in future.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)