Can't start version 146. Error with Kernel32.dll

0 favourites
  • 2 posts
From the Asset Store
Use this game pack to create your own game, modify the existing game or simply take a look and see how it was made.
  • Hi everyone!

    I wanted to try the newest version 146, but after installing it I can not start Construct 2.

    I get an error message that roughly translates (from Swedish)

    "Can�t find procedural address * in DLL-file Kernel32.dll."

    The "*" is rather a symbol that looks a bit like a diamond shape.

    I have Windows 7, 64-bit. Chrome version 30.0.1599.66 m.

    I also downloaded the latest stable drivers for my graphics card I could find (Geforce GTX570, driver: 327.23)

    I have the licensed version of Construct 2.

    If I reinstall the version I had before (version 139) everything works fine again.

    The weirdest thing is, that just after installing version 146, before you click "finish", you get the option to tick the box: "Launch Construct 2". If I tick that box, C2 actually launches, but then I can�t open any example caps or projects (I get the same error message as before). If I close the program I can�t restart it again. I�ve tried running it "normally" and as Administrator.

    When searching the forum I found an old thread which included the words "Kernel32", and one recommendation there was to run SFC/Scannow in the command prompt to see what it said. I did that, but it just said everything was normal.

    Any ideas what I could do?

    Any more information I can give? I�m not a particularly experienced computer user, so to be honest I actually don�t even know what Kernel32.dll is.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I found this thread ( that indicates that this problem pops up from time to time. It seems to somehow resolve itself when later versions come out.

    When I get home I?ll try the beta 145,144 and so on and see if they work by any chance.

    Stable version 139 works fine, as stated.

    Hopefully next stable version after 146 will work for me as well.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)