Cant Launch C2

0 favourites
  • 14 posts
From the Asset Store
A cool way for kids to write and practice English Alphabets
  • Cant launch Construct or open any projects.

    In task manager it does create a background process for C2 but thats about it. Actual application wont open.

    Running windows 10. Havnt had any issues in the past.

  • reinstall? are you using r219? 216? i'm on win10 and it works just fine, it's probably something else. did you install with auto detect or 32 bit? maybe you've selected wrong.

    also check graphics drivers? viruses/spyware/malware?

  • Sadly a new installation did not fix the problem.

    Tried turning antivirus off, that didnt help.

    Running latest drivers. installed 64bit.

  • can you post a screenshot of your taskbar and task manager processes ( best if you have process explorer because more compact.. ) ... lorer.aspx

  • Are you launching c2 as stand-alone or via Steam client? No matter - here's how I would try to fix your problem; you may or may not have tried all of these but here goes...

    I would first suggest you uninstal both c2 and the nw.js for c2. Then have a look in ../users/yourname/AppData to see if c2 has stored any files there (this happens with steam installation and, I think, if you drag c2addon files into the editor rather than install the plugins yourself). After that, scan your registry and fix any errors (I would recommend ccleaner - the free version). After all of that pain, a system restart will be required and should set you straight for a good installation.... Good luck!

  • Standalone. stable

    I have completely uninstalled

    Checked %appdata% and it didnt have anything.

    ran ccleaner and it did its magic.


    Still not working.

  • I forgot to add - when you uninstall c2, do you delete all of your plugins that remain on the c drive in the exporters folder? It could be that one of them is corrupt.

  • I forgot to add - when you uninstall c2, do you delete all of your plugins that remain on the c drive in the exporters folder? It could be that one of them is corrupt.

    Deleted all of it when uninstalled and installed it fresh :/

    Very odd because I never had issues in the past. Didnt use my computer for quite a few months so nothing has changed besides a new powersupply haha. Other than that i guess windows updated and stuff. Seeing as it was like 4 months behind due to a dead psu.

    Perhaps I should throw in an Ashley

  • Try run the program in compatibility mode for example Windows Vista Service Pack 2 or Windows 7

  • i suppose that's a steam installation?

    have you tried downloading installer from site and installing?

    p.s. you've got 6.2 GB of processes - that's... too much XD i mean it's ok because you got 32 GB of ram, but do you really need all that?

    here's some i've noticed that could be removed (if you're not using them (i'll compare to mine)):

    • akamai session
    • bluetooth
    • bonjour
    • chrome cleanup ?
    • display fusion (why are you using this on win10?)
    • dropbox update
    • geforce experience
    • intel management services - they are all useless (as much as i've tried and looked they didn't do much, they just get in the way)
    • itunes / ipod helper (unless you have iSomething)
    • java updater
    • msi afterburner (i suppose you're overclocking )
    • nvidia driver + network services
    • bandwidth meter?
    • sierra service?
    • skype updates

    now i suppose you've got this all installed and you're using most of it, but if you're not just uninstall all unneeded programs, most of them that "offer" performance and what not actually make your system work worse then it actually can and just slow it down. now you could run a spyware / virus check aswell as you might get suprised by some random unexpected thing.

    i know what your answer probably will be: "but i need all these, i'm a programmer / designer / etc.." and that's fine if you work with it.

    i've got my developer stuff on my pc installed (lots of it) but still i have less processes then you. (and i've got mercurial, visual studio, sqlserver, photoshop, loads of other tools, java, flash, etc.. ) they all have their processes but i've terminated them all, since i prefer manual work mostly. (most secure and fastest in execution).

    p.s. also check your startup programs there might be some wierd things too. disable unneeded.

    also someone mentioned ccleaner registry cleaning. try this:

    uninstall c2,nwjs, clean appdata for c2, and run ccleaner, but beforehand install ccenhancer. (make sure you tick everything (except maybe browser history / session / passwords, and the things that pop up a window) and clean your drive aswelll. then run cc registry clean.

    cc registry clean is pretty shallow, so i'd recommend you install wise registry cleaner. make sure in options you select "deep" cleaning and select "back up registy before cleaning", i think it's on by default. clean registry with this tool. you can also compress it with defrag for higher performance (it will restart your pc).

    then try installing stable and check if it works.

    if nothing helped sofar - it might be that your UAC (if you have it ON) is causing problems when running app.

    also - open event viewer and check application logs. if there are yellow/red logs, try finding one with construct2.exe and details about the error. paste here.

    windows shouldn't be a problem, i've been updating from 10240 to 10586 + all the new updates - and everything works ok.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • I've never heard of this problem before. All I can suggest is open regedit and delete the entire key HKEY_CURRENT_USER\SOFTWARE\Scirra\Construct2. That will reset all settings. If that doesn't help, I'm not sure what it could be...

  • Good news! The problem has been fixed.

    tried everything you guys said and then some. Almost decided to give up or do a clean windows install.

    In the end...

    I'm assuming my geforce experience/my graphics drivers were the cause. Corrupted damaged who knows. Going through all my folders to delete and free up space, removing unwanted things... There were a handful of drivers/downloaded files in my nvidia folders, so i deleted and tried doing a fresh install on that. Still using the same driver build but C2 works now. Might have been some issue from going from a previous driver. I tend to run beta drivers so honestly cant say the underlying cause. My current driver is not even beta.

    C2 was the only program being affected which I find very odd. Oh well...

    Thanks for the help!

  • well its a new day and a new year! Sadly, the issue came back so I really dont know what to do for an actual solution to whatever is going on.

    switched to windows build 1511 (KB3116278)

    Everything seems to be working now. So I dont believe it was actually a graphic driver issue.

    Hopefully this is the complete fix.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)