Can't run C2 as Administrator

  • I recently purchased a Personal C2 copy thru Steam. I wanted to preview my game on a local network so I followed a tutorial to do that. One thing I learned from that tutorial is that I need to Run C2 as Administrator.

    I then located the Construct2.EXE file and right clicked and selected 'Run as Administrator' option. However, the Steam program then tried to re-install C2 as a Free version, but obviously I've already purchased and installed the Personal version. I'm not sure whether I need to proceed to re-install it as Free version - I highly doubt that if I do that it will screw up my Personal version.

    Did anyone who purchased C2 via Steam encounter the same issue as I had. Any suggestions or advice on how to solve this? Thanks in advance.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Maybe run steam as administrator then launch C2 from inside steam?

  • Thanks, BluePhaze. As you advised, I ran Steam as the Administrator first and then set up the local network IP in C2, it really worked. Thanks again for your suggestion.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)