Can't kill Construct2.exe

0 favourites
  • 15 posts
  • Recently I have been more active and working quite a bit with Construct 2. Most of time I get to a point where I can't preview the project anymore and I found out that it was due to multiple Construct2.exe instances still running, and unfortunately they cannot be terminated through the task manager (or some other software I tried).

    Sometimes I suddenly have up to 7 instances sitting there, eating away at my RAM. This is very annoying, since one has to restart the computer in order to fix the issue. Anyone else got the same trouble or knows what might cause this? If this is a known problem I totally missed it so far.

    I'm using Windows 7 Home 64bit btw.

  • Sometimes after spending some time in C2, can't preview project as well and need to restart C2 to fix that.

    Speaking of a "multiple Construct2.exe instances" to be honest never looked in to the task menager so can't really confirm that.

    So, unable to preview project after some time in C2 - yes.

    Multiple instances - not sure, will check that when it happens again for me.

    Using Windows 7 Ultimate 64bit.

  • I obviously use C2 a lot in my testing and I've not managed to catch a "ghost process" like you describe yet. So I suppose it's rare, but happens a lot on your computer for some reason. Is there anything you can do that reliably reproduces it?

  • Also got the unclosed processes regularly with r50 on WinXP-SP2, but able to close with task manager, so only a minor inconvenience. Only run a few tests with r51 and noticed it's still occurring. Haven't tried r52 yet.

    Anyone else?

  • Can I ask if there's any particular reason you're holding back from staying up to date with r52? Newer builds often have important bug fixes.

    I'll double check the code for when C2 shuts down and see if I spot anything.

  • I've made a possible fix for the next build - it was to do with the HTTP server shutting down. It should be out in a day or two. When it comes, let me know if that fixes it!

  • Can I ask if there's any particular reason you're holding back from staying up to date with r52?

    Just that i've switched to prepaid data plan thru Android phone (only 1GB per month :P) but have increased this slightly from September.

    r50 was 13MB. r51 was close to 18MB with examples. And r51 was slow download (either my side, or during high demand) but disconnected mid download with your server not supporting resume. (been catching up on six months of developments/demos so was running out of bandwidth ;)

    Anyhow, r53 has just downloaded super fast without hitch, and ghost process appears resolved. Http server explains it well. Good catch!

  • I was working with r53 for a bit just now and unfortunately it happened again. At least I have a hunch now what triggers it.

    When I make changes to a project, then close Construct and click on "Don't save" in the appearing dialog, the exe seems to remain and can't be terminated anymore. Restarting Construct 2 will work, but one can't preview anymore as mentioned.

    Not 100% sure that's what causes it for me, but at least it just happened that way.

  • What do you mean you can't preview? What happens? If the preview is broken, that suggests it's still the HTTP server... hmm...

  • When I click preview, it basically freezes C2 with a little window saying "Starting preview". But of course nothing happens.

  • Bumping this, because the issue is still there. And it got increasingly frustrating to me, because I'm trying my hand at some plugin development lately. Which means I'm opening and closing Construct 2 even more often.

    And it happens a lot. On the average I would say every four times I open C2, the process remains after closing it again, and as a result I cannot preview anymore. As I mentioned Construct2.exe can't be killed from the task manager.

    I don't do anything special, it just eventually happens. So I don't know what to tell in order to reproduce it. Maybe other users with the same issue can shed a little more light on this too (are there any?).

    Running as permanent background processes are Threatfire, Avira Antivir and ZoneAlarm. I was fishing a little, trying to close the programs, but it doesn't seem to matter. C2 still behaves the same.

    So yeah, I'm a little lost here.

  • looks like a buggy java installation.

    consider un/reinstall java and c2.

  • Are you on the latest C2 release?

    What OS and service pack are you on?

    I think it's most likely the HTTP server not shutting down - if you always use File preview mode, does it still happen?

  • looks like a buggy java installation.

    consider un/reinstall java and c2.

    The Construct 2 installation should be fine, since I'm always keeping up with the latest version and uninstall the older one before. And I've had this problem during many different versions of C2.

    I also doubt it's java. Keeping up with the updates there as well, haven't had any problems. Thanks for your suggestions though.

    Are you on the latest C2 release?

    Yes, I'm on r63. Happened on previous releases as well.

    What OS and service pack are you on?

    Win7 Home Premium 64bit no service pack installed

    I think it's most likely the HTTP server not shutting down - if you always use File preview mode, does it still happen?

    I think you're right. Slipped my mind to try the File preview tbh, and yes, it doesn't happen if you use File preview mode. I tried to make it happen about a dozen times. Nada. Then switched to HTTP and after 4 tries I had my Construct2.exe ghost process again.

    File preview helps some, but for quite a few features you would need HTTP preview.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Well, it's always tricky to fix issues I can't reproduce... no way to know if I've fixed it. Still, I'll revise the http server code and see if I can come up with something...

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)