Bug - game ignores user input

0 favourites
  • 10 posts
From the Asset Store
Total customisation of the input! You can combine inputs from all peripherals. Make your game accessible for everyone!
  • Hi!

    I've stumbled upon this tool while I was researching HTML5 game creation and it looked cool so I thought I'd give it a try.

    I made a (very) simple project so I could see how your system performs.

    The simple application is like that, there's a single sprite that responds to:

    S - Rotate 45 degrees clockwise

    Tab - Rotate 45 degrees counter-clockwise (As I expected it wouldn't work nicely, so don't bother with this, it will switch control to the browser and do crazy things)

    Enter - Reset rotation

    Now, that TAB bug is reasonable, but what bothered me was this. I tried adding some very basic CSS and other content (Text and image) to see if it would interfere with the game (Nothing serious, take a look at the source) , and then I found quite a weird bug. Seems like that after you click anywhere on the screen, the game no longer responds to user input!

    No matter how much i tweaked the CSS nothing solved it, so I randomly pressed the keys and found something even weirder! After you lose control, if you press a certain key combination, and then click on the canvas, the control is restored!

    After losing control, do: Enter, S S S, Tab Tab, Enter and then click on the canvas. Control should be restored! (It works for me most of the times, at least...)

    The game: http://eztax.zxq.net/bug.html

    The capx source: http://eztax.zxq.net/bug.zip

    I hope this bug report can help you! I'm looking forward for more stable versions of Construct 2!

  • that actually makes sense. There is a canvas object that everything is being drawn on and in order to take input it has to have focus. when you click off of it it loses focus and wont respond to it. When you click on the canvas it regains focus. at least that is the way it should work.

  • The problem is that without the key combination clicking the canvas won't restore any control!

  • have you tried just double clicking?

  • Yes, nothing but that combination works, as weird as it may sound. Try it yourself, there's a link to the bugged HTML file.

  • No I did try it. It works fine for me. if I click off and then double click it again it works fine.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • Really? are you trying my html file or you're rebuilding it yourself? it could be because the css or content I added

    which browser you use? I get the bug in both firefox and chrome.

  • Did anyone reproduce the bug yet?

  • I tried your file in chrome. even if it is a bug you should always post bugs to the tracker if you want them fixed not on the forums

  • Right! Posted in the tracker, thank you!

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)