Amazon Underground incorrect sash icons issue

0 favourites
  • 6 posts
From the Asset Store
Platformer tileset with underground mining cave for creating action adventure games
  • Hi!

    I've published my game in Amazon Underground. Now I've build new version of the and uploaded it on the Amazon Developer Portal. I've submited the new version and get following fail:

    "App launch icon contains incorrect sash."

    Did somebody get the same error? How did you solve it?

    I build my apps with Intel XDK

  • How could you publish to "Amazon Undergroud"? I guess you need a special plugin so they can track user play time and show commercials at the beginning. Is there something available? Or do you mean you tried to publish to the amazon store. I think these are two different things.

  • Try Construct 3

    Develop games in your browser. Powerful, performant & highly capable.

    Try Now Construct 3 users don't see these ads
  • When you publish app on Amazon, you can submit it for Amazon Underground Program ... checklists

  • olkina hey did you resolve this issue? I have the same situation

  • Hello i ve got same problem now they told me that i must load icons in drawable folders as xhdpi,hdpi etc.

    on page there is some faqs. ... guidelines im trying to fix this trough this but im just trying and trzing no special tutorial for how to do this. i need update my game and i cant. On contact us they told me which icons is missing but they forgot to tell me where they in apk exactly need to be uploaded. So i just trying useing theyr FAQs for help and dont know i uploaded it maybe 20 times yet and it still say the same im useing for compilation. If i will be succesful i will let you know. Or please if you know something new just help a bit here thank you

  • So people: I've solve this problem........ First for compilation of APK i used Android studio. here is how> ... id-studio/

    for makeing key i used this it is needed in android studio you can use key.keystore.jks file if you have any or create a new one, or sign it by old way trough command promt. LINK:

    Subscribe to Construct videos now

    It is two years old so now you have a new java folder so use the new one.

    I tried and intel XDK but it doesnt work and still same: App icon contains incorrect sash Problem will be in name of icons probably or something but Android studio works perfect for Amazon underground Export here are the sizes of sashed icons and i used Drawable-* and mipmap-* folder in apk for just to be sure it will pass trough here is sizes:

    List of missing sash files:


    mdpi - missing icon(Expected icon size 48x48)

    tvdpi - missing icon(Expected icon size 64x64)

    hdpi - missing icon(Expected icon size 72x72)

    xxhdpi - missing icon(Expected icon size 144x144)

    xxxhdpi - missing icon(Expected icon size 192x192)

    Name every icon in special folder as icon.png make it 24bit with transparency And last thing i used Photoshop for sashing icons it is free for some time so just download from adobe cloud and install after follow this tutorial>

    Last thing if you are not familiar with android studio just search for some tutorials after few hours of studying you will learned it.

Jump to:
Active Users
There are 1 visitors browsing this topic (0 users and 1 guests)